Investigate SMTP connection timeouts on bm50

RESOLVED INCOMPLETE

Status

Release Engineering
General
RESOLVED INCOMPLETE
6 years ago
5 years ago

People

(Reporter: rail, Assigned: rail)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
2012-12-24 08:45:01-0500 [Uninitialized] SMTP Client retrying server. Retry: 4
2012-12-24 08:45:03-0500 [-] Pulse <0x196d8e60>: Processed 12 events (0 heartbeats) in 0.00 seconds
2012-12-24 08:45:22-0500 [Uninitialized] SMTP Client retrying server. Retry: 3
2012-12-24 08:45:42-0500 [-] Sorted 31 builders in 0.06s
2012-12-24 08:45:43-0500 [Uninitialized] SMTP Client retrying server. Retry: 2
2012-12-24 08:46:04-0500 [Uninitialized] SMTP Client retrying server. Retry: 1
2012-12-24 08:46:25-0500 [Uninitialized] Unhandled error in Deferred:
2012-12-24 08:46:25-0500 [Uninitialized] Unhandled Error
        Traceback (most recent call last):
        Failure: twisted.internet.error.TCPTimedOutError: TCP connection timed out: 110: Connection timed out.

2012-12-24 08:46:25-0500 [Uninitialized] Stopping factory <twisted.mail.smtp.ESMTPSenderFactory instance at 0xa9057e8>
(Assignee)

Comment 1

6 years ago
grep twisted.internet.error.TCPTimedOutError twistd.log*|wc -l
329
since Dec 21
(Assignee)

Comment 2

6 years ago
It looks like a random error:
$ grep ESMTPSender,client twistd.log* |wc -l
959
(normal output)


Maybe it was caused by mail.build.mozilla.org settings. Something like simultaneous connection limit or something similar?


:justdave - do you have any idea why it may happen?

Unfortunately I have no better logs.
Flags: needinfo?(justdave)
(In reply to Rail Aliiev [:rail] from comment #2)
> :justdave - do you have any idea why it may happen?

No.  We don't have any connection limits.  Can you telnet to it?  Netflow open?
Flags: needinfo?(justdave)
(Assignee)

Comment 4

5 years ago
telnet/nc worked fine (that particular machine is not available anymore). I tried that again from another machine in the same subnet and telnet/nc worked fine.

Closing as incomplete. I'll reopen it if we hit this again.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
I think https://bugzilla.mozilla.org/show_bug.cgi?id=840405#c5 identified the root cause of this bug, as well as worked toward a solution.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.