Fancy intro at ref. URL freezes but does not crash Mozilla

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Kent Paul Dolan, Assigned: Alexandru Savulov)

Tracking

({hang})

Trunk
mozilla0.9.3
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9+) Gecko/20010520
BuildID:    2001052020

When the reference URL is opened with Mozilla, the fancy intro runs to
a conclusion, but Mozilla then freezes and stops responding, without
crashing to produce a talkback report.  The same URL opens fine with
Netscape 4.72.

Reproducible: Always
Steps to Reproduce:
1. Paste URL into location of blank browser window.
2. Press return.
3.

Actual Results:  Browser freezes, stops responding to any mouse or keyboard input.


Expected Results:  Completed fancy intro, gone on to next display of corporate
home page.


The URL used to access the problem page had been suffixed with "index.cfm" by
the time Mozilla froze.
(Reporter)

Updated

17 years ago
Keywords: hang

Comment 1

17 years ago
win98 2001052320, not seeing this. However, the next page is not loaded
correctly, i have to reload for it to show.

Comment 2

17 years ago
WFM on Win32 build 2001052304
(Reporter)

Comment 3

17 years ago
Something is apparently unstable among the builds; I retested with win32
2001052020, failed as previously.  Then I installed win32 2001052404, and hang
occurred just as with the earlier build.

Windows98b, in case that makes a difference, and 128MByte RAM installed.
wfm with win2k build 20010525.. (CVS opt).
Reporter: Have you flash installed ?
Have you tried a new profile ? (run "mozilla -profilemanager").
(Reporter)

Comment 5

17 years ago
Answers to previous query:

1) I do not have flash installed, at least not for Mozilla; this is a clean
   Mozilla installation (now at release 2001052708 for win32, talkback
   version), the only changes being that the profile is copied (automatically
   at first Mozilla launch after Mozilla installation) from my Netscape 4.72
   installation, the history retention is set by me from 9 to 366 days, the
   number of backward URLs remembered is set by me from 50 to 200, and
   my bookmark.html and history.dat files are copied from my previous 
   installations of Mozilla daily builds.

2) I have not tried a new profile (I'd be unlikely to know what I was doing),
   but the page loads normally from Netscape 4.72, the copy from which Mozilla
   captures the profile it is using, so changes would be likely to make things
   worse rather than better.

The hang still occurs after the zoom sequence but before loading of the normal
site homepage, as before, for Windows98b, as of this build, 2001052708.

Comment 6

17 years ago
I managed to reproduce it. Build ID 2001053004 on Win98, 196MB RAM. The deal
with my attempt is that I click the skip-intro (flash intros are today what
image intros used to be 5 years ago: USELESS and ANNOYING) link, which takes you
to index.cfm, but nothing renders. Gives me a "Document Done (1.54 secs) but
just white. Reload render it. Now, get this: I close that window, open a new
window, go to the mail url, click the link again, and index.cfm load the first
time. Same happens on a 3rd and 4th try, etc. Works, just not on the first try.
(Reporter)

Comment 7

17 years ago
Since Gary Hodge has managed to reproduce a flavor of this bug (for me it still
just _hangs_ Mozilla if I do _not_ bypass the intro), this bug should probably
change from unconfirmed to some other status, but I don't know your rules.

Bye, all, thanks for the chance to help; I have to leave the net for a spell.
confirming based on the comments
Assignee: asa → karnaze
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen

Comment 9

17 years ago
Reasigning to alexsavulov for analysis/triage and moving to m0.9.2.
Assignee: karnaze → alexsavulov
Target Milestone: --- → mozilla0.9.2
(Assignee)

Comment 10

17 years ago
moving to 0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3
(Assignee)

Comment 11

17 years ago
marking works for me (w2k, w98 with 2001072403)
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
for the QA: also WFm with win2k build 20010724..
You need to log in before you can comment on or make changes to this bug.