[Settings][Cellular&Data] When you open data connection, the warning design is different than UX design

RESOLVED DUPLICATE of bug 836609

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 836609
6 years ago
5 years ago

People

(Reporter: ypwalter, Assigned: arthurcc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, blocking-basecamp:-)

Details

(Whiteboard: [mno11][triaged:1/18] )

(Reporter)

Description

6 years ago
This bug is mainly for v1.1(shira)
MozTrap Test Case: https://moztrap.mozilla.org/manage/case/5924/

*Phone: Unagi
2012-12-23 23:43:28
https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/date-unagi/2012/12/2012-12-21-23-43-28/

*How to reproduce:
  1. Go to "Settings" app
  2. "Cellular & Data"
  3. Turn on "data connection"

*Expected Result: 
    MTR-23264
    https://www.dropbox.com/s/jbyjevqh3zbusrj/Roaming%20UI_Dec%2013.pdf

*Actual Result:
    Not as the roaming ui designed
(Reporter)

Updated

6 years ago
blocking-b2g: --- → shira?
blocking-basecamp: --- → ?
Assignee: nobody → skrishnan
blocking-b2g: shira? → shira+
blocking-basecamp: ? → -
(Reporter)

Comment 1

6 years ago
The most up-to-date result by 2012-12-27 date build:

It still doesn't have the  MTR-23264 second screen shown.
Functionality not completed

Can't test on a roaming card as for now.
local 3G doesn't have such warning, but it should have it
(suspect foreign roaming 3G card doesn't have the warning too)

Comment 2

6 years ago
Walter the pdf you are referring to is a wireframe and not a mock (if the screen looks acceptable and native it should be fine), also it shows that screen only once after that the second screen is never shown , we just show a inline message after the first attempt. 

(In reply to Walter Chen from comment #1)
> The most up-to-date result by 2012-12-27 date build:
> 
> It still doesn't have the  MTR-23264 second screen shown.
> Functionality not completed
> 
> Can't test on a roaming card as for now.
> local 3G doesn't have such warning, but it should have it
> (suspect foreign roaming 3G card doesn't have the warning too)

Comment 3

6 years ago
also can you post screen captures of the existing screen ?
(Reporter)

Comment 4

6 years ago
The first screen on the pdf is the current showing screen.

The second screen on the pdf won't show.

The third screen on the pdf is partially the same except there is no warning for "data connection"
(Reporter)

Updated

6 years ago
QA Contact: wachen

Comment 5

5 years ago
I think my changes are not there then , can you paste a link to the build that you are using to test ?
(Reporter)

Comment 6

5 years ago
I had it in my original description:


*Phone: Unagi
2012-12-23 23:43:28
https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/date-unagi/2012/12/2012-12-21-23-43-28/

Comment 7

5 years ago
ok we figured that my changes have not been pushed into shira , hence the confusion , will update once done

Updated

5 years ago
Whiteboard: [mno11]

Comment 8

5 years ago
they are in shira now
Whiteboard: [mno11]
Whiteboard: [mno11]
(Reporter)

Comment 9

5 years ago
I checked today's shira in hg. It's not there yet. Are you sure that it works now?
Flags: needinfo?(skrishnan)
(Reporter)

Comment 10

5 years ago
Sorry, my fault. The change was in.

Waiting for pvt build so that I can change this to verified fixed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(skrishnan)
Resolution: --- → FIXED

Comment 11

5 years ago
Reopen, please do attach commit link.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 12

5 years ago
Code landing

https://github.com/mozilla-b2g/gaia/commit/a86ee423e1c7b0855551613fa801030ce1b94b5b
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Whiteboard: [mno11] → [mno11][triaged:1/18]
Arthur, just want to make sure these are in v1-train/master as well. Thanks
Assignee: skrishnan → arthur.chen
Resolution: FIXED → DUPLICATE
Duplicate of bug: 836609

Updated

5 years ago
blocking-b2g: shira+ → -
You need to log in before you can comment on or make changes to this bug.