nsStorageStream crash with modified test_streamcopier.js

RESOLVED WORKSFORME

Status

()

Core
XPCOM
--
critical
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: WeirdAl, Unassigned)

Tracking

({crash, testcase})

Trunk
crash, testcase
Points:
---

Firefox Tracking Flags

(firefox20-)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 695654 [details] [diff] [review]
testcase patch

Steps to reproduce:
(1) Apply the testcase patch.
(2) In your objdir with tests enabled:
make -C netwerk/test/ SOLO_FILE="test_streamcopier.js" libs check-one

###!!! ASSERTION: index out of bounds: 'indx < segCount', file c:\repos\trunk\mozilla\xpcom\io\nsSegmentedBuffer.h, line 58
(Reporter)

Updated

5 years ago
tracking-firefox20: --- → ?
Attachment #695654 - Attachment is patch: true
(Reporter)

Comment 1

5 years ago
OK, I found something very interesting:  the storage input stream isn't reading from the beginning of the storage stream.
(Reporter)

Comment 2

5 years ago
Apparently it matters when I initialize the storage input stream:  if I do so before there's any data in the output stream, then the crash happens.

Comment 3

5 years ago
When do we think this regressed? Are we certain this test represents a normal user scenario?

If this is a longstanding issue it's unlikely we'd track for a specific release.
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

5 years ago
I'd be very surprised if this was a regression of any kind.

Updated

5 years ago
Crash Signature: xul!nsStorageInputStream::ReadSegments+0x00000000000000E3 (c:\repos\trunk\mozilla\xpcom\io\nsstoragestream.cpp, line 424) xul!nsStorageInputStream::Read+0x000000000000001D (c:\repos\trunk\mozilla\xpcom\io\nsstoragestream.cpp line 397) xul!nsScrip&hellip; → [@ nsStorageInputStream::ReadSegments]

Comment 5

5 years ago
(In reply to Alex Vincent [:WeirdAl] from comment #4)
> I'd be very surprised if this was a regression of any kind.

Given that, if you think this should still be pursued asap, please nominate with more context as to why you think this should track for a specific release.
tracking-firefox20: ? → -
Does this still reproduce?
Flags: needinfo?(ajvincent)
Keywords: regressionwindow-wanted
(Reporter)

Comment 7

3 years ago
No, it looks like it's working now. :-)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ajvincent)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.