Closed Bug 824651 Opened 7 years ago Closed 7 years ago

Tab bar height is doubled on Windows 8 devices with touchscreens

Categories

(Firefox :: Tabbed Browser, defect, minor)

18 Branch
x86_64
Windows 8
defect
Not set
minor

Tracking

()

RESOLVED FIXED
Firefox 21
Tracking Status
firefox20 + fixed
firefox21 --- fixed

People

(Reporter: nitarshanr, Assigned: Felipe)

References

Details

Attachments

(3 files)

Running the desktop version of Firefox on a Windows 8 device with a multitouch screen causes the height of tabs in the tab bar to be doubled, and also moves tab navigation elements to the horizontal middle of the tab bar. In this case the bug occurred on a laptop. Bug was present in the release version of Firefox 17, and is also present in the Firefox 18 beta.

I'd speculate that some code meant to increase the size of tab elements for better navigation by fingers on tablets is causing this bug on newer non-tablet devices (laptops/desktops) that are equipped with touchscreens.
Did you test in safe mode and with a new profile to eliminate potential add-ons/prefs issues?
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Same behavior?
Flags: needinfo?(nitarshanr)
I tested the browser with those conditions, and the behaviour was indeed the same.
Flags: needinfo?(nitarshanr)
This is apparently on purpose, they're trying to make touch targets larger.  There are css entries specifically targeting touch enabled devices.  For example:

@media (-moz-touch-enabled) {
  .tabbrowser-arrowscrollbox > .scrollbutton-up,
  .tabbrowser-arrowscrollbox > .scrollbutton-down,
  #TabsToolbar .toolbarbutton-1 {
    min-width: 8.1mozmm;
  }

  .tabs-newtab-button {
    min-width: 10mozmm;
  }

  .tab-content {
    min-height: calc(6.8mozmm - 7px); /* subtract borders from the desired height */
  }
}

Note the minimum height for tab content.
Madhava, Gavin, Dão, this seems to be an intentional state but I don't think it's actually very useful. I'm using a dozen touch-enabled Windows 8 machines so I see this in desktop Firefox and given how not touch accessible is the rest of the browser, making the tab height so tall is mostly just an eyesore. Desktop Firefox in Windows 7 and 8 is not touch capable and we shouldn't pretend that it is. Can we please disable/remove this for tab height so our desktop browser doesn't look so silly on touchscreen Windows machines?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(madhava)
This was originally done in bug 503889 when we expected classic Windows desktop to get more touch support. Since Metro is the touch interface on Windows now I think indeed it doesn't make sense anymore to keep this for non-metro Firefox. I can remove those unless Madhava says we should keep it.
Assignee: nobody → felipc
Status: NEW → ASSIGNED
Attached patch PatchSplinter Review
Remove all the CSS changes for desktop Firefox on touch-enabled screens.

There is one part that I'm not sure if it should be removed or not: on the new tab page, the close/pin controls were always displayed on touchscreens (as opposed to on hover only). It doesn't change any dimensions, just when those buttons are displayed.  This patch also removes that but I can keep that if wanted.
Attachment #707711 - Flags: review?(dao)
(In reply to :Felipe Gomes from comment #6)
> There is one part that I'm not sure if it should be removed or not: on the
> new tab page, the close/pin controls were always displayed on touchscreens
> (as opposed to on hover only). It doesn't change any dimensions, just when
> those buttons are displayed.  This patch also removes that but I can keep
> that if wanted.

I think we should keep it.
Attached patch Patch v2Splinter Review
Posting the patch version that does not remove the newtab always-show controls
Attachment #707827 - Flags: review+
Attachment #707711 - Flags: review?(dao)
https://hg.mozilla.org/mozilla-central/rev/78ecce4ba214
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Duplicate of this bug: 814479
Duplicate of this bug: 687251
Would it be reasonable to ask for approval to land this on mozilla-beta for Firefox 20?  The patch is very low-risk, since it only removes some CSS styles, and those styles are used only on Windows touch-screen hardware.
Comment on attachment 707827 [details] [diff] [review]
Patch v2

Yeah, it's a simple change (only CSS removal) and if many more users are starting to get affected by it now (with the new Win8 touch hardware out there), it's probably worth to fix it 6 weeks sooner.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Old CSS styles for touch that have been unmaintained for a long time.
User impact if declined: Weird styling around the toolbar for users with Win8 touch hardware when using the classic desktop (not metro)
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): very small
String or UUID changes made by this patch: none

I've verified that the same patch applies on beta.
Attachment #707827 - Flags: approval-mozilla-beta?
(In reply to Matt Brubeck (:mbrubeck) from comment #13)
> Would it be reasonable to ask for approval to land this on mozilla-beta for
> Firefox 20?  The patch is very low-risk, since it only removes some CSS
> styles, and those styles are used only on Windows touch-screen hardware.

Thank you Matt and Felipe. Yes. If we can uplift this early, that would be great. It's an eye sore and we're seeing more and more touch-capable Windows 8 devices in the market where users are encountering this.
Comment on attachment 707827 [details] [diff] [review]
Patch v2

Approving, low risk fix for uplift.
Attachment #707827 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.