Inapproriate DIV element in TEXTAREA - Show All Tags mode

VERIFIED DUPLICATE of bug 88036

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 88036
17 years ago
17 years ago

People

(Reporter: rubydoo123, Assigned: glazou)

Tracking

Trunk
mozilla1.0
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ui])

(Reporter)

Description

17 years ago
in Show All Tags Mode a DIV element is displayed when there is default text for 
a textarea. Sample to use:

<form action="foo.html" method=post>
  <textarea name="textblock" rows="2" cols="26">TEXTAREA element</textarea>
</form>
(Reporter)

Updated

17 years ago
Keywords: correctness
Priority: -- → P3
Whiteboard: [ui]
Target Milestone: --- → mozilla1.0

Comment 1

17 years ago
I hope we can change to using Daniel's new ":before" strategy for showing the
icons in Show All tags mode. We would need a new rule like:
textarea  div {
  /* don't do whatever we do to show icon /*
}
to surpress showing the DIV (which actually exists? annonymous content?)
Status: NEW → ASSIGNED
(Assignee)

Comment 2

17 years ago
If that DIV is anonymous content, it should not be visible in the DOM when you
crawl from a parent to its list of children. I guess that the only easy way to
solve the problem is the CSS rule proposed by Charley. The other way, directly
in the style engine, is definitely cleaner and I think that a bug should be filed
about it.

I think that the DIV really exists in the tree and is an anonymous content.
TEXTAREA is semantically equivalent to a mailcomposer window so we need a block
container for everything inside...
The bug about ISINDEX is exactly equivalent. An ISINDEX _is_ a text inoput
field. I guess it is too an anonymous element.
(Assignee)

Comment 3

17 years ago
reassigning to myself
(Assignee)

Comment 4

17 years ago
really reassigning; sorry for spam
Assignee: cmanske → glazman
Status: ASSIGNED → NEW
(Assignee)

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 88036 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.