Closed Bug 824737 Opened 9 years ago Closed 9 years ago

Save Image on Google image search page saves images with .html extension

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox18 affected, firefox19 affected, firefox20 verified, firefox21 verified, fennec+)

VERIFIED FIXED
Firefox 21
Tracking Status
firefox18 --- affected
firefox19 --- affected
firefox20 --- verified
firefox21 --- verified
fennec + ---

People

(Reporter: wesj, Assigned: wesj)

References

Details

Attachments

(1 file)

Using the "Save Image" context menu item on Google image search page saves images with .html extension. I suspect that we're using the href on the link as our filename rather than using the images src attribute.
Duplicate of this bug: 825430
tracking-fennec: --- → ?
OS: Linux → Android
Hardware: x86 → ARM
tracking-fennec: ? → +
Attached patch PatchSplinter Review
I can't quite see the difference here, but this works....
Attachment #700646 - Flags: review?(mark.finkle)
Comment on attachment 700646 [details] [diff] [review]
Patch

Differences I can see:
contentDisposition and type are set to "" in our old code, but to null in saveImageURL

We'll need more testing on lots of different pages/images to make sure this si not a regression. We are early enough in the cycle to get the testing.
Attachment #700646 - Flags: review?(mark.finkle) → review+
Comment on attachment 700646 [details] [diff] [review]
Patch

This is too simple not to uplift.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Forever
User impact if declined: Images are saved with the wrong extension making it really hard to reopen them
Testing completed (on m-c, etc.): Landed on mc today
Risk to taking this patch (and alternatives if risky): Really low risk. Moves us to use the same code desktop does. Very little change from what we had ("" -> null)
String or UUID changes made by this patch: none
Attachment #700646 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/9ada9208c1bf
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 700646 [details] [diff] [review]
Patch

Mobile only, longstanding bug. Approving for Aurora to get this into the hands of users sooner.
Attachment #700646 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Firefox 21.0a1 (2013-01-18)
Firefox 20.0a2 (2013-01-18)
Device: Galaxy Nexus
OS: Android 4.1.1

Images are not saved as .html any more. Marking bug as verified fixed.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 777267
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.