If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][E-Mail] There is no option to add an attachment when composing a new message from the e-mail app.

VERIFIED FIXED

Status

Firefox OS
Gaia::E-Mail
--
enhancement
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: J Zimbrick, Assigned: dkuo)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18+ verified, b2g18-v1.0.1 wontfix)

Details

(Whiteboard: testrun 4, interaction [UX-P1], [TEF_REQ])

(Reporter)

Description

5 years ago
Repro Steps:
1. Update device to build 20121217070202.
2. Open the e-mail app.
3. Press the "+" button in the top right corner to compose a new a message.
4. Observe that there is no option to add an attachment to a message from this screen.

Actual Results:
There is no option add an attachment to a new e-mail when using the e-mail option.

Expected Results:
According to test case #3893 there will be an option to attach a file from the e-mail screen.

Notes:
User is able to send e-mails with attachments, but they have to do so from the Gallery app.

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 827259

Comment 2

5 years ago
Issue repros in Build 20130104070203

Repro Steps
1. Launch Email
2. Click Plus sign in upper right corner
3. Press the "+" button in the top right corner to compose a new a message.
4. Observe that there is no option to add an attachment to a message from this screen.

Actual Results:
There is no option add an attachment to a new e-mail when using the e-mail option.

Expected Results:
According to test case #3893 there will be an option to attach a file from the e-mail screen.

Notes:
User is able to send e-mails with attachments, but they have to do so from the Gallery app.

Comment 3

5 years ago
UCID: webact-002
https://moztrap.mozilla.org/results/case/62642/
Whiteboard: testrun 2
(Reporter)

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM

Updated

5 years ago
blocking-b2g: --- → tef?
This got dropped as a requirement/user story for v1.  Mostly because a file picker needs to be implemented and we didn't have the time to do so.

Test case needs to be updated.  I'll update the test case.
blocking-b2g: tef? → -
tracking-b2g18: --- → +
Flags: in-moztrap?(nhirata.bugzilla)

Updated

5 years ago
Duplicate of this bug: 834688

Comment 6

5 years ago
[TEF_REQ] as Feature required for TEF build.
Whiteboard: testrun 2 → testrun 2, interaction [UX-P1], [TEF_REQ]

Updated

5 years ago
blocking-b2g: - → leo?
blocking-b2g: leo? → leo+
Depends on: 836497
Depends on: 836498

Comment 7

5 years ago
There is no place on the email to where you have the ability to add an attachment.  You can pick a picture and have it be shared by email but directly in the email icon it is not implemented at this time. Test case number #2878.  As per comment 4 this has been removed per V1.  

Build ID: 20130130070201
Kernel: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4593f3e765eb
Gaia   f7f5a0cd17e3d04308cc5850b254947e127122b9
Whiteboard: testrun 2, interaction [UX-P1], [TEF_REQ] → testrun 4, interaction [UX-P1], [TEF_REQ]
Disabling test case.  Marking as enhancement as I'm pretty sure we want this.
Severity: normal → enhancement
assigned to domanic, + Casey for UI spec.
Assignee: nobody → dkuo
Flags: needinfo?(cyee)
(In reply to Wayne Chang [:wchang] from comment #9)
> assigned to domanic, + Casey for UI spec.

Hi Wayne - I've been working with Casey on the flows for this one and have posted them to dropbox for comment:

https://www.dropbox.com/s/5giljes7ao9gyrg/email-attachments.pdf

I'll be fleshing these out with annotations this week but let me know if you have any questions or concerns in the meantime.

- Rob
Flags: needinfo?(cyee)
Email-138 was created as a test case for v1.1 +ing Moztrap
Flags: in-moztrap?(nhirata.bugzilla) → in-moztrap+
Dominic, do you have anything you need to implement this bug? Could you do it or reassign someone on this?
Flags: needinfo?(dkuo)
(Assignee)

Comment 13

5 years ago
Tim, the patch of bug 838006 should also slove this issue, and that patch is waiting for Andrew's review, setting dependency.
Depends on: 838006
Flags: needinfo?(dkuo)
dkuo's fix of bug 838006 resolves this bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Will this be fixed by the wholesale uplift of the email program?
no patches here, marking wontfix.
status-b2g18: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
wontfix doesn't seem correct to me;  we know what fix solved this even if it's not in this bug.  anyway, marking it 

verified on Leo with:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/0c71cbc5fe0c
Gaia   a7b0810580afc734f3d5e441914fe895f9c1923e
BuildID 20130508230207
Version 18.0
Status: RESOLVED → VERIFIED
status-b2g18: wontfix → verified
You need to log in before you can comment on or make changes to this bug.