[Keyboard] Input type= Email

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Keyboard
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Deepa Subramanian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: testrun 4)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 695787 [details]
App UI input = email keyboard

## Environment : Unagi phone, v1.0 build ID 20121217070202

Installing Keyboard app UI and selecting Input type "EMAIL" does not bring up "keyboard with "@", ".com", "+", "-", "_" and "," 

## Repro:

1) Install Keyboard application UI from http://bit.ly/UgIMN4

 on to the device

2) Click on the app "UI tests" from homescreen
3) Select "Keyboard" test from the "UI tests" list
4) click On the input type = Email 
5) Email Keyboard is not seen 

## Expected:
Email Keyboard (with @ .com + - _ and ,)

## Actual:
Keyboard without "@", ".com", "+", "-", "_" and ","
(Reporter)

Comment 1

5 years ago
Also, the "ç" is miising on the row "asdfghjkl". Verified Build 20121217070202 v1.0

Comment 2

5 years ago
defect is also occurring for the "<input type='email' multiple >" TC #4798
(Reporter)

Comment 3

5 years ago
still found on Unagi device Build ID: 20130104070203
v1.o

Comment 4

5 years ago
UCID: owd-2878
https://moztrap.mozilla.org/results/case/63086/
Whiteboard: testrun 2

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM

Comment 5

5 years ago
Build ID: 20130130070201
Kernel: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4593f3e765eb
Gaia   f7f5a0cd17e3d04308cc5850b254947e127122b9
UCID: 2684
Test suite: Keyboard
This issue still reproduces
Whiteboard: testrun 2 → testrun 4
(Reporter)

Comment 6

5 years ago
as per the Comment 5, This issue is still found for brazilian keyboard on 

Build ID: 20130130070201
Kernel: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4593f3e765eb
Gaia   f7f5a0cd17e3d04308cc5850b254947e127122b9
Fails test case:https://moztrap.mozilla.org/runtests/run/712/env/296/?pagenumber=1&pagesize=100&sortfield=order&sortdirection=asc&filter-id=4851&filter-id=4899&filter-suite=209
UCID: OWD-2684
Test suite: Keyboard

Comment 7

5 years ago
The Email Keyboard can be accessed through the Email App, and displays properly.

Resolving works for me in Nightly Build ID: 20130213071150
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6fec2938ac1e
Gaia: 07aa79239ced90a7ca0e8da8829fbcb330c42e9f
Kernal: December 5
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.