Payments form is not getting saved leaving the app in "incomplete" status

VERIFIED FIXED in 2013-01-03

Status

Marketplace
Developer Pages
P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: krupa, Assigned: kumar)

Tracking

2013-01-03
Points:
---

Details

(URL)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/developers/app/test-app-aardvark89/payments/ for an app which supports only Firefox OS
2. In the paid/in-app tab, select a price tier, currencies and  add a bank account.
3. Save changes 
4. Reload the Compatibility & Payments page.


observed behavior:
Bank account details get saved but not currency selection. This results in the app remaining in the "incomplete" status. Any time, a change is saved, we see " We encountered a problem contacting the payment server.." error.

screencast: http://screencast.com/t/unrbHq9kA82

Comment 1

6 years ago
Since we no longer have a currency form, can you test to see if this is still reproducible? I don't think that the currency form is to blame (the message you're seeing is thrown when there's an error generated by Solitude), but at least then we can rule out the currency form.
(Reporter)

Updated

6 years ago
Summary: Currency selection is not getting saved leaving the app in "incomplete" status → Payments form is not getting saved leaving the app in "incomplete" status
(Reporter)

Comment 2

6 years ago
This is happening even after currency field was removed.
I still see this after bug 824765
Priority: -- → P1
Target Milestone: --- → 2013-01-03
I'm pretty sure when make premium is fixed (bug 824751) then this will work again because until then the form isn't getting saved all the way.
bug 824751 landed. Is this still happening? I can't reproduce it.
(Reporter)

Comment 6

6 years ago
(In reply to Kumar McMillan [:kumar] from comment #5)
> bug 824751 landed. Is this still happening? I can't reproduce it.

This works now.

Comment 7

6 years ago
Thanks kumar and andym!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

6 years ago
verified at https://marketplace-dev.allizom.org/developers/app/test-app-polarbear92/status


Note that bug 822806 is still open.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.