Copy during submission incorrect for paid apps

RESOLVED FIXED

Status

Marketplace
Developer Pages
P2
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: krupa, Assigned: basta)

Tracking

Points:
---

Details

(Whiteboard: u=patron c=pmt p=1, URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/developers/submit/app
2. Select Paid option and complete the app submission process
3. Notice the copy on the "Finished!" page - "We've got your app saved and ready to go! Your app is currently awaiting review, and will show up on listing pages and in search once it is reviewed. Until then, feel free to tweak your app's details and settings.

expected behavior:
The copy says - "Time to set up your Payments to have all that cash rolling in!" or something similarly cute.

observed behavior:
Actual copy is inaccurate since it says that app is awaiting pending when it will be in incomplete status until the Payment set up has been completed.
(Reporter)

Comment 1

6 years ago
Created attachment 695796 [details]
screenshot
LOL. Well this is a bug.
If the "paid" option is chosen can we just push them right to the payment configuration instead of seeing this page?
Priority: -- → P2
Whiteboard: u=patron c=pmt p=1
(Assignee)

Updated

6 years ago
Assignee: nobody → mattbasta
(Assignee)

Comment 4

6 years ago
https://github.com/mozilla/zamboni/commit/6ed811c2f699503e27b7aab7ba6fc2f62aae2d5b
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.