Connection to payment server intermittently fails.

VERIFIED FIXED in 2013-01-03

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: vcarciu, Assigned: andy+bugzilla)

Tracking

2013-01-03
x86_64
Windows 7
Points:
---

Details

(URL)

(Reporter)

Description

6 years ago
Prerequisites:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121216 Firefox/20.0

Steps to reproduce:
1.Go to MP dev hub page https://marketplace-dev.allizom.org/developers/
2.Select an Firefox OS app and try to make it a paid app : https://marketplace-dev.allizom.org/developers/app/test-app-lenght333/payments/
3.Select a price tier, a payment account and click on "Save Changes" button

Expected results:
Changes are successfully saved and application is seen as paid on FF OS devices.

Actual results:
The message "We encountered a problem connecting to the payment server. " is intermittently displayed.

Please see screencast for this bug : http://screencast.com/t/PtsGXa1dtj

NOTES:
Some times the connection works(See "Test App (applicationteast)" paid app) as expected and the app is visible as paid after changes , but the error is displayed very often(9 out of 10 attempts)
(Assignee)

Updated

6 years ago
Assignee: nobody → amckay
Target Milestone: 2012-12-27 → 2013-01-03
(Assignee)

Comment 1

6 years ago
These are specific issues like bug 825682. In that, we also got verbose logging so we should be able to track the errors in sentry. If there's any specific errors please re-file.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

6 years ago
Verified as fixed : http://screencast.com/t/QpkX3ChQfTg6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.