Changing locale (language) bring the lock screen back on top.

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: nbp, Assigned: kaze)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:-, b2g18+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
tested on Vivien's twilight version.

STR:
 - Open settings app.
 - Tap on Language
 - Tap on the drop down menu
 - Tap on Français
 - Tap on Ok

Seen:
 - The lock screen comes back on top.

Expected:
 - Go back to the language sub-menu of the settings app.

Kaze explained me that this bug was cause by the relocalization of the lock screen which has a higher z-index than any other application causing it to appear again when it is relocalized.
blocking-basecamp: ? → -
tracking-b2g18: --- → +
Duplicate of this bug: 825873
Summary: Changing local bring the lock screen back on top. → Changing locale (language) bring the lock screen back on top.

Comment 2

6 years ago
Pretty annoying for us that actually change the language of the phone. I'm OK with bb-, though. CCing folks so that they know we already have a bug on this.
(Assignee)

Updated

6 years ago
Assignee: nobody → kaze
Duplicate of this bug: 828342
(Assignee)

Comment 4

6 years ago
Created attachment 700290 [details]
patch proposal

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): l10n.js
User impact if declined: getting on l10n contributors’ nerves
Testing completed: manual
Risk to taking this patch (and alternatives if risky): none
Attachment #700290 - Flags: review?(timdream+bugs)
Attachment #700290 - Flags: approval-gaia-master?(21)
Attachment #700290 - Flags: review?(timdream+bugs) → review+
Comment on attachment 700290 [details]
patch proposal

Sounds safe and fix a blocker imo. a=me.
Attachment #700290 - Flags: approval-gaia-master?(21) → approval-gaia-master+
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.