[Gaia][Gallery] Delete Video does not work correctly

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Gallery
P3
normal
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: rdaub, Assigned: djf)

Tracking

({b2g-testdriver, unagi})

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [feedback])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
ENVIRONMENT:
Unagi phone, build 12/27


STEPS to REPRO:
1. Open up Gallery
2. Tap on the trashcan icon to delete video
3. Tap "OK" to confirm delete video


EXPECTED:
Video should be deleted instantly, and the next picture/video in the gallery should be shown.


ACTUAL:
1. The video remains visible and playable in the gallery.

2. Tapping the Home button, then opening up the gallery:
   the video remains visible and playable.

3. Force-closing the gallery (Holding the Home button, then swiping up the gallery):
   the gallery icons are reloaded, and the video is deleted.

Thanks!!
Basically the video as well as gallery app are caching the information somewhere and not refreshing is what I am guessing?  cc'ing David Flanagan
Another case of this would be to open the gallery or video app, add stuff to the sdcard and then look at the gallery and video app for the newly added files.  They won't be seen.
(Reporter)

Comment 3

5 years ago
Possibly related to bug 821912
Triage: BB+, C4, P3 - delete function not work
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C4 (2jan on)
(Assignee)

Updated

5 years ago
Assignee: nobody → dflanagan
(Assignee)

Comment 5

5 years ago
Created attachment 696587 [details]
link to patch on github

This bug was caused by a copy/paste error, to the fix is just one line long.
Should be easy to review :-)
Attachment #696587 - Flags: review?(dkuo)
Comment on attachment 696587 [details]
link to patch on github

Typo fix ( I checked media db source) looks good to me...
Attachment #696587 - Flags: review?(dkuo) → review?(jlal)
Attachment #696587 - Flags: review?(jlal) → review+
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 823859
(Assignee)

Updated

5 years ago
Duplicate of this bug: 823568

Comment 10

5 years ago
Created attachment 696768 [details]
Thumbnails appear after deleting a video

Issue persists on Unagi Build 20121231070201. After deleting the video a gray thumbnail is seen in Gallery where the video used to be.

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

5 years ago
Shoot. The dreaded gray thumbnail issue.  I would expect gray thumbnails to appear only at the very bottom or top of the thumbnail list. Is that what you see?  Can you get the same gray thumbnail to appear when deleting a photo?

Comment 12

5 years ago
The issue I am seeing now that appears to be reproducible, is that the thumbnail of the photo or video is still visible in Gallery after deleting them from the Select screen and then going back to Gallery. If you end task the Gallery and then re-open Gallery you then see the photo or video thumbnail for about 5-10 seconds, then it disappears. This on Unagi Build 20121231070201.
(Assignee)

Comment 13

5 years ago
I can't reproduce this. 

mlevin: in the screenshot you attached, the blue 'marching ants' progress indicator is visible, which indicates that the gallery is still scanning for new photos.

Can you reproduce this when the phone is not scanning?  And also, do the gray squares go away when the scanning process is complete?

If this bug only occurs when deleting files while scanning is going on, then:

a) it is probably harder to fix

b) it is less likely to affect users and maybe shouldn't be blocking.

If you can still reproduce it, could you give more precises steps to reproduce?
Flags: needinfo?(mlevin)

Comment 14

5 years ago
Issue seems to be fixed on Unagi build 20130102070202. In other words after deleting the video from the Select screen and going back to Gallery thumbnail view the thumbnail does not appear. Going to resolve this bug.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?(mlevin)
Resolution: --- → WORKSFORME

Comment 15

5 years ago
Bug seems to be fixed. Verified on Unagi Build ID: 201302011070202
Kernel: Dec 5
Gecko:http://hg.mozilla.org/releases/mozilla-b2g18/rev/59fbbbbba801
Gaia:21cedfd1787f4aff26721fc0f160e771db5cd67d
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.