[Lockscreen] service provider shown wrongly when roaming

VERIFIED FIXED in B2G C4 (2jan on)

Status

Firefox OS
Gaia::System::Lockscreen
P3
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: ypwalter, Assigned: rik)

Tracking

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, blocking-basecamp:+, b2g18+ fixed, b2g18-v1.0.0 fixed, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
According to tw gaia team members' feedback. The lock-screen should should the roaming call/data services provider. It should not show the original service provider.

For example, if you have a China Mobile card, when you are roaming in Taiwan Mobile, it should show Taiwan Mobile, and vice versa.
(Reporter)

Updated

6 years ago
blocking-b2g: --- → shira?
blocking-basecamp: --- → ?
(Reporter)

Comment 1

6 years ago
2012-12-27 date build from pvt server
Triage: BB+, P3, C4 - severe usability issue
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C4 (2jan on)
Assignee: nobody → yurenju
Is it still happening now that we are using the MobileOperator helper everywhere in the system app?
is this related to bug 825123?
Flags: needinfo?(wachen)
(Reporter)

Comment 5

6 years ago
It's not related.

This one is just about showing wrong service provider's name everywhere.
Nothing affecting functionality

bug 825123 is about it can't get the current/previous service provider's network settings, and it will not have data roaming in this case. It's not the same root cause, and this one is affecting the real functionality of using data roaming.
Flags: needinfo?(wachen)
Etienne, this bug occurred with China Mobile sim card, I will verify it with AT&T.
below is result:
===============
AT&T (correct)
  network.longName: Taiwan Mobile Co. Ltd
  network.shortName: Taiwan Mobile
  iccInfo.spn: null
  iccInfo.isDisplaySpnRequired: false
  iccInfo.isDisplayNetworkNameRequired: true

China Mobile (incorrect)
  network.longName: Taiwan Mobile Co. Ltd
  network.shortName: Taiwan Mobile
  iccInfo.spn: -�5
  iccInfo.isDisplaySpnRequired: true
  iccInfo.isDisplayNetworkNameRequired: false

per talked with Gecko member Patrick, isDisplaySpnRequired value comes from sim card.

Is looks like a sim card issue.

Joe, Do you have contact window of Telefonica who can confirm the right behaviour?
Flags: needinfo?(jcheng)
Hi Daniel, do you think you can provide more information on comment 7? what's the target market SIM should behave like? Thanks 

and QAWANTED for confirmation on the roaming behavior using target market SIMs.
Flags: needinfo?(jcheng) → needinfo?(dcoloma)
Keywords: qawanted
(Reporter)

Comment 9

6 years ago
(In reply to Joe Cheng [:jcheng] from comment #8)
> and QAWANTED for confirmation on the roaming behavior using target market
> SIMs.

Joe, is it possible for us to get a targeted market sim card?
I think that whenever you are roaming, the service provider name should be the one of the operator is providing you the service in the roaming country, regardless the values of the ICC flags. 

Adding dpv to the loop to double check.
Flags: needinfo?(dcoloma) → needinfo?(dpv)

Updated

6 years ago
See Also: → bug 824267
I will implement according Daniel comment Tuesday if no addition comments coming.
Keywords: qawanted
(Assignee)

Comment 12

5 years ago
I can reproduce here in Berlin with a Telenor SIM card.

shortName:  Vodafone
longName:  Vodafone D2 GmbH
isDisplaySpnRequired:  true
isDisplayNetworkNameRequired:  false
spn:  TELENOR

It should display Vodafone (or maybe Vodafone D2 GmbH) but it displays TELENOR.
(Reporter)

Comment 13

5 years ago
Cool, that means more SIM cards have the same issue. In that case, developers should better handling similiar situation so that it can be solved!
(Assignee)

Comment 14

5 years ago
Stealing this from Yuren.

I have a patch on my branch https://github.com/Rik/gaia/tree/roaming-825121 but I'm waiting to check with Telefonica people if it's the right behaviour.
Assignee: yurenju → anthony
(Assignee)

Updated

5 years ago
Flags: needinfo?(brg)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 824267
Hi, 

Beatriz and I have been discussing about this issue. We think the carrier name shown in the lock screen should always be the roaming network the device is attached to. 

Thanks!
David
Flags: needinfo?(dpv)
Flags: needinfo?(brg)
(Assignee)

Comment 17

5 years ago
Created attachment 699652 [details] [diff] [review]
Review pointer to https://github.com/mozilla-b2g/gaia/pull/7414

Thanks David and Beatriz. Here's the patch then.
Attachment #699652 - Flags: review?(timdream+bugs)
Attachment #699652 - Flags: review?(timdream+bugs) → review+
https://github.com/mozilla-b2g/gaia/commit/8869378ddac902b09fc6d4838b29f2af36381438
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 19

5 years ago
Verified Fixed

Device: Unagi
Build Identifier: 20130113070202
Update channel: 
   nightly b2g18 (pvt server)  
   unagi.zip	13-Jan-2013 08:06 	100M	 
   https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi-eng/
Git commit info: 2013-11-13 15:15:51
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
Given that this landed prior to the 1/25 branching for v1.0 we are marking this fixed in v1.0.1 as well.
blocking-b2g: shira? → -
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → fixed
status-b2g18-v1.0.1: --- → fixed
tracking-b2g18: --- → +
You need to log in before you can comment on or make changes to this bug.