Closed Bug 825127 Opened 7 years ago Closed 6 years ago

about:memory in modern includes old CSS version

Categories

(SeaMonkey :: Themes, defect)

defect
Not set

Tracking

(seamonkey2.26 affected, seamonkey2.27 affected, seamonkey2.28 fixed, seamonkey2.29 fixed, seamonkey2.30 fixed)

RESOLVED FIXED
seamonkey2.30
Tracking Status
seamonkey2.26 --- affected
seamonkey2.27 --- affected
seamonkey2.28 --- fixed
seamonkey2.29 --- fixed
seamonkey2.30 --- fixed

People

(Reporter: Matti, Assigned: neil)

Details

(Keywords: modern)

Attachments

(1 file)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17a1
Build identifier: 20121224003038

The CSS of about:memory is an old version and the about:memory page is basically unstyled 
The link in view source for the css is chrome/modern/skin/modern/global/aboutMemory.css

The css in the classic skin only contains an @import rule.
Keywords: modern
OS: Windows 7 → All
Hardware: x86_64 → All
Attached patch Proposed patchSplinter Review
I imported the content aboutMemory.css to get most of the styles, but also button.css to make the buttons look vaguely Modern. I couldn't import plugins.css to set the background and link colours so I had to copy them. I couldn't do much about the checkbox so I just removed its Classic appearance.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8440349 - Flags: review?(philip.chee)
Comment on attachment 8440349 [details] [diff] [review]
Proposed patch

> +div.section, div.opsRow {
> +  background-color: #C7D0DB;
There are no hits for #C7D0DB in modern. However #C7D0D9 appears to be the background colour for most of the widgets. To be consistent we should use #C7D0D9.

> +input[type="checkbox"] {
> +  -moz-appearance: none;
Sometimes I get a 2px inset border and sometimes without the inset. I couldn't track down why this happens.

> I couldn't do much about the checkbox so I just removed its Classic appearance.
[Might need to add rules for :hover :focused :active but I didn't try too hard]

r=me with the background colour fixed.
Attachment #8440349 - Flags: review?(philip.chee) → review+
(In reply to Philip Chee from comment #2)
> > +div.section, div.opsRow {
> > +  background-color: #C7D0DB;
> There are no hits for #C7D0DB in modern. However #C7D0D9 appears to be the
> background colour for most of the widgets. To be consistent we should use
> #C7D0D9.
Yeah, that was a typo, I used DOM Inspector to find the colour I wanted but it only gave me the rgb() form and I misconverted it back to hex.

> > +input[type="checkbox"] {
> > +  -moz-appearance: none;
> Sometimes I get a 2px inset border and sometimes without the inset. I
> couldn't track down why this happens.
Depends on whether it has focus, I think.

> > I couldn't do much about the checkbox so I just removed its Classic appearance.
> [Might need to add rules for :hover :focused :active but I didn't try too
> hard]
I can't do anything about the appearance of an HTML checkbox, sorry.
Pushed comm-central changeset 812f5cce4d7f.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.30
Comment on attachment 8440349 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 856917 (probably)
User impact if declined: about:memory doesn't function correctly in Modern
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #8440349 - Flags: approval-comm-beta?
Attachment #8440349 - Flags: approval-comm-aurora?
Comment on attachment 8440349 [details] [diff] [review]
Proposed patch

a=me
Attachment #8440349 - Flags: approval-comm-beta?
Attachment #8440349 - Flags: approval-comm-beta+
Attachment #8440349 - Flags: approval-comm-aurora?
Attachment #8440349 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.