Change Email Format from Plain Text to HTML cannot show Format Toolbar

RESOLVED DUPLICATE of bug 140800

Status

RESOLVED DUPLICATE of bug 140800
18 years ago
11 years ago

People

(Reporter: wkfx2003-bugzilla, Assigned: sspitzer)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
If reply an plain text email, the new mail will be in Plain Text. I changed
Option->Format->HTML and try to View->Toolbars->Formatting Toolbar the toolbar
is not shown.

Comment 1

18 years ago
builid: 2001052308 linux, 2001052408 win98, 2001052209 worksforme. 
The formart toolbar is displayed in the compose window. Reporter check to see 
in the menu item view|formatting toolbar is checked. The only way I don't see it 
appearing with html compose is if you have unchecked the formatting toolbar.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 2

18 years ago
verified as worksforme
Status: RESOLVED → VERIFIED

Comment 3

18 years ago
No, [View]-[Show/Hide]-[Formatting Toolbar] doesn't work
with 2001052411/Linux.

If you open a compose window with HTML mode, you can show/hide
formatting toolbar.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 4

18 years ago
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 5

18 years ago
Bug 77221 for [Option]-[Format].
(Reporter)

Comment 6

18 years ago
I send myself an Plain Text email (with Option->Format->Plain Text)
After I receive the email, I "Edit as New". The Format toolbar is not shown,
even I checked View->Toolbars->Formatting
reassign to varada
Assignee: ducarroz → varada

Comment 8

18 years ago
reassign->esther->intelligent send
QA Contact: sheelar → esther

Comment 9

18 years ago
IMO, switching from plain text to HTML should automatically show the format 
toolbar, and switching from HTML to plain text should automatically hide it.

Comment 10

18 years ago
*** Bug 89320 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
Mail compose window doesn't have [View]-[Show/Hide]-[Formatting Toolbar] now.
Have the spec changed? Or should this bug marked as invalid?
taking all of varada's bugs.
Assignee: varada → sspitzer

Comment 13

16 years ago
Related: bug 78794.

Comment 14

16 years ago
Verified as DOESNOTWORKFORME in
Mozilla 1.3.1 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030425

_My_ summary line would say
Impossible to Compose HTML Messages (Format Menu Missing in Compose Options)

However, this bug can be detoured by
- quitting Mozilla
- editing the .mozilla/<user>/<salt>/prefs.js file as follows: replace
    user_pref("mail.identity.id2.compose_html", false);
  with
    user_pref("mail.identity.id2.compose_html", true);

- restarting Mozilla.

There appears to be no menu entry anywhere to enable or disable the user's
ability to compose HTML.

Comment 15

15 years ago
Using Thunderbird 0.4 the same problem is found, in either direction.  You reply
to an HTML message and you can't change it to plain text.  This is completely
unusable.

This should be upgraded to critical.
I have not used Thunderbird, so I can't say anything viz. comment 15, but...

In comment 14, sdall@jet.uk is misled in saying "There appears to be no menu 
entry anywhere to enable or disable the user's ability to compose HTML."  
True, not a menu; but since at least 1.3, this setting has been settable in the 
UI, specific to the mail account:  Edit|Mail&NewsgroupSettings.
In 1.3 and 1.4, the checkbox is on the account's top-level settings page; as of 
1.5 it's been moved to the Composition&Addressing page.


The plain-text compose window no longer has the Options|Format submenu (nor the 
Format or Insert menus), so the initial report is no longer valid; if an HTML 
compose window switches between Options|Format|Plain and Options|Format|HTML, 
the format toolbar is hidden/shown (per bug 77221).

What is really desired here is a way to switch between the two modes.  I'm 
duping this to a bug that's explicitly about that.

*** This bug has been marked as a duplicate of 140800 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.