Startup fails: libgdk_pixbuf.so.2: open failed

RESOLVED WONTFIX

Status

SeaMonkey
Build Config
--
critical
RESOLVED WONTFIX
17 years ago
14 years ago

People

(Reporter: nesti, Assigned: Dawn Endico)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; I; SunOS 5.8 sun4u)
BuildID:    20010508

Trying to start the downloaded binary on a (quite fresh) Solaris 8. 

The startup fails because of a missing library libgdk_pixbuf.so.2 in the loading
of libgfx_gtk.so:

**************************************************
nsNativeComponentLoader:
GetFactory(/share/local/mozilla0.9/mozilla/components/libgfx_gtk.so) Load FAILED
with error: ld.so.1: ./mozilla-bin: fatal: libgdk_pixbuf.so.2: open failed: No
such file or directory
**************************************************
(seven times; then it runs runs, nothing comes out, and you kill it)

Should this library be added to the requirements list or added to mozilla
directly?  

Thanks to all, 
keep along with the good work,
cheers,
Fabrizio Nesti -- Medialab -- SISSA

Reproducible: Always
Steps to Reproduce:
1. download, install & run mozilla-sparc-sun-solaris2.8-0.9.tar.gz

Comment 1

17 years ago
That's a contributed build.  None of the official mozilla.org builds require
gdk_pixbuf. 

Dawn, do we need to update the distribution howto to tell people to not use
gdk_pixbuf?  Or do we let the contributed ports continue to build with whatever
and make a clearer separation between the official builds and the contributed
ones? If gdk_pixbuf-devel is on the box, then mozilla will use it.


Assignee: cls → endico
Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug has not been touched since 2001-05-24,therefore this reminder.

Reporter could you please retest this with a current build and let us know if
the problem is still present or the bug can be closed

Comment 3

14 years ago
We still no control over what contributed builds do but we stopped building
against gdk pixbuf years ago.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.