[email] Can't add a gmail account



Firefox OS
5 years ago
5 years ago


(Reporter: Yoric, Unassigned)



Firefox Tracking Flags

(Not tracked)


Using 20121212 in French.

I cannot add a gmail account. The screen is there but button "Next" is always disabled. Also, the label of field "Nom" is not clear: should this be my real name or my gmail login?
(In reply to David Rajchenbach Teller [:Yoric] <away until Jan 7th> from comment #0)
> Using 20121212 in French.

This build is way too old; please update your device and re-open or re-file if the problem still exists.  The placeholder phrasings have been updated with the fix for bug 809552 landed yesterday and which should be present in today's nightly.  In English, "Name" is now "Your name".
Last Resolved: 5 years ago
Resolution: --- → INVALID
So, what should I do? Flash the device?
Just upgraded. Works nicely with 20121226.

Comment 4

5 years ago
It seems there is a regression with gmail account. It is not possible to set that account. The device remains in this screen: Please wait while your account is set up.
Unagi build:

1. Open Email
2. Type your name, user address and Password
3. Click on Next
Resolution: INVALID → ---

Comment 5

5 years ago
Just after reproducing the issue, tested with another account and it worked, but with the first one is still failing.
The accounts are both aaaaa@gmail.com, the only difference in principle is the user and password.
Please provide the error code from the account creation failure and a logcat.  Please see:

Comment 7

5 years ago
After many tries and wating for long time I got my account working and although I remove it, restart the device, cannot reproduce the problem. I will follow the instructions to get a logcat in case I am able to reproduce the problem again
Couldn't create an account from gaia master (be85eeb1c6fa4d999f4a42ab7be0fc46ade9226a), nothing displayed (stays on "please wait while your account is set up", like in Comment 4).

In the logs: 

I/GeckoDump( 7426): ERR: onerror reporting: Error: Load failed: activesync/codepages/AirSync: undefined @ app://e
mail.gaiamobile.org/js/ext/alameda.js : 834
E/GeckoConsole( 7426): [JavaScript Error: "Error: Load failed: activesync/codepages/AirSync: undefined" {file: "a
pp://email.gaiamobile.org/js/ext/alameda.js" line: 834}]
I/GeckoDump( 7426): ERR: onerror reporting: Error: Timeout for modules:  @ app://email.gaiamobile.org/js/ext/alam
eda.js : 1051
E/GeckoConsole( 7426): [JavaScript Error: "Error: Timeout for modules: " {file: "app://email.gaiamobile.org/js/ex
t/alameda.js" line: 1051}]

Don't have a proper regression range but it works at 76185af4659982e750bb625f78bd5c81346eefb0.
Note that comment 8 was spun out to be bug 853908 because it was a new regression which is now fixed.

Comment 10

5 years ago
Does this still need to be open? It seems everything has been resolved.
I had no issues adding a gmail account with
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/6c2493de1441
Gaia   9c6e9decdd1333f3b6dbed22538a85361cf944dc
BuildID 20130425070204
Version 18.0
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.