The default bug view has changed. See this FAQ.

URL Locks up Firefox and all Tabs

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Elliot, Unassigned)

Tracking

({perf})

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

I went to http://www.thegoodman.cc/ on Firefox 17 under Windows.


Actual results:

The browser locked up entirely, changing tabs became impossible, stopping loading became impossible, UI ceased to update and the browser could only be closed with Task Manager.


Expected results:

The browser should have remained responsive at least, ideally rendering the tab correctly, at worst marking the tab as crashed.

Comment 1

4 years ago
.pat {
background-image: radial-gradient(rgba(0, 0, 0, 0.1) 1px, transparent 1px);
}

causes this problem.

likely bug 632324
Component: Untriaged → Graphics
Product: Firefox → Core
Depends on: 632324
Keywords: perf
Hrm, I wonder if 632324 is really the same issue. As that seems to be fixed on nightly with the new Gradient cache. I wonder if for some reason this is having a cache miss in the gradient cache for some reason.
(In reply to Bas Schouten (:bas.schouten) from comment #2)
> Hrm, I wonder if 632324 is really the same issue.

You're right. With Bug 823147 fixed (tested with http://hg.mozilla.org/integration/mozilla-inbound/rev/d1b79578a1bd) the Site is WFM.
Depends on: 823147
No longer depends on: 632324
Thanks for the bug report Elliot.

WFM with D2D with bug 632324. There's still some bugs that will make it faster when running without D2D.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.