Closed Bug 825327 Opened 7 years ago Closed 7 years ago

Warning in FTU app

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

x86_64
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mrbkap, Assigned: mrbkap)

References

Details

Attachments

(1 file)

While running the FTU app, after hitting "next" for the last step (the one that leads into the tutorial) I get:

E/GeckoConsole( 7733): [JavaScript Error: "TypeError: steps[this.currentStep] is undefined" {file: "app://communications.gaiamobile.org/ftu/js/navigation.js" line: 222}]

in adb. This is an easy bug to fix.
Attached patch Easy patch, v1Splinter Review
This patch does beg the question: why do we use an object with numbered steps (beginning at 1 rather than 0) rather than an array?
Attachment #696408 - Flags: review?(francisco.jordano)
Comment on attachment 696408 [details] [diff] [review]
Easy patch, v1

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):

Changing the reviewer to fcampo, as he is the one working on FTU and I'm on PTO till the 7th of January.

Thx.
Attachment #696408 - Flags: review?(francisco.jordano)
Attachment #696408 - Flags: review?(fernando.campo)
Attachment #696408 - Flags: approval-gaia-master?(francisco.jordano)
Comment on attachment 696408 [details] [diff] [review]
Easy patch, v1

easy patch, low risk. Thanks for fixing it mrkbap

and about your question, FTU was created when the design was still changing, so the object had sense at the moment. Later on, as always happens with this, refactor was less critical than bug fixing. The app certainly needs full revisiting and refactor to improve performance, but deadlines and workload are taking us away from it at the moment :)
Attachment #696408 - Flags: review?(fernando.campo) → review+
Comment on attachment 696408 [details] [diff] [review]
Easy patch, v1

Non risky change
Attachment #696408 - Flags: approval-gaia-master?(francisco.jordano) → approval-gaia-master+
Hi Blake, couldn't find the PR in github for this bug, can you do it and merge?

Already have approval and r+

Thanks a lot!
Duplicate of this bug: 815017
Merged in https://github.com/mozilla-b2g/gaia/pull/7284

Thanks.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.