Submitting email address as login

VERIFIED WORKSFORME

Status

()

Core
HTML: Form Submission
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: rmurray, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I can not log into sites using an email address of with numeric characters 
after the '@'.  I am using Netscape 6.01 (Mozilla/5.0 (Windows; U; Windows NT 
5.0; en-US; m18) Gecko/20010131 Netscape6/6.01) and Mozilla 0.9 (Mozilla/5.0 
(Windows; U; Windows NT 5.0; en-US; rv:0.9) Gecko/20010505 build 2001050515).  
The problem was produced at 'https://rigel.symantec.com/cgi-bin/esd1.pl?sku=07-
12-00014&segment=electronic&subsite=us&promocode=ECSALES&VENICE=x' and them was 
reproduced at 'http://bugzilla.mozilla.org/query.cgi?GoAheadAndLogIn=1'.  The 
problem was not reproduced from either site when using 'IE 5.0 
(5.00.3103.1000)'.

Comment 1

17 years ago
reassigning
Assignee: rods → pollmann

Comment 2

17 years ago
Filling out the form at 
https://rigel.symantec.com/cgi-bin/esd1.pl?sku=07-12-00014&segment=electronic&su
bsite=us&promocode=ECSALES&VENICE=x

with an email address like test@123.net, and submitting it goes to the credit 
card entry field without any errors... This is on build 2001-05-24-04-trunk 
windows 98
(Assignee)

Comment 3

17 years ago
I was also able to verify that using a numeric email address to log into the
bugzilla page submitted the correct query string with the latest builds.

Since this bug was reported with an older build, assuming it has been fixed
already, and marking this bug worksforme.

rmurray@110.net, if you have time and would like to try a build that probably
has a fix for your bug, you can get one here:

http://mozilla.org/releases/

Or, if you are feeling brave, you can download the very latest, bleeding edge
build (like the ones we used to verify that this bug is fixed now) here:

http://ftp.mozilla.org/pub/mozilla/nightly/latest/
(warning: these are likely to be a little unstable!)

thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
works for me build 2001-06-25-09-trunk
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.