Closed Bug 825427 Opened 7 years ago Closed 6 years ago

Intermittent browser_responsiveruleview.js and browser_responsivecomputedview.js | Test timed out followed by Found a tab after previous test

Categories

(DevTools :: Responsive Design Mode, defect)

x86_64
Linux
defect
Not set

Tracking

(firefox29 wontfix, firefox30 fixed, firefox31 fixed, firefox-esr24 wontfix)

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 --- wontfix
firefox30 --- fixed
firefox31 --- fixed
firefox-esr24 --- wontfix

People

(Reporter: jdm, Assigned: pbro)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=18327543&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound debug test mochitest-browser-chrome on 2012-12-28 14:02:23 PST for push 22310b95d586

slave: talos-r3-xp-065

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveruleview.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveruleview.js | Found a tab after previous test timed out: data:text/html,<html><style>div%20{%20%20width:%20500px;%20%20height:%2010px;%20%20background:%20purple;}%20@media%20screen%20and%20(max-width:%20200px)%20{%20%20div%20{%20%20%20%20%20width:%20100px;%20%20}};</style><div></div></html>
Same situation as bug 822290 it appears.
Flags: needinfo?(bbenvie)
Assignee: nobody → bbenvie
Flags: needinfo?(bbenvie)
The same JS error than in bug 986284 seems to be causing this one to fail too.
Sorry Brandon for taking this from you, but I've fixed the same thing already in other tests, this will be a quick one.
Assignee: bbenvie → pbrosset
Duplicate of this bug: 822290
Summary: Intermittent browser_responsiveruleview.js | Test timed out followed by Found a tab after previous test → Intermittent browser_responsiveruleview.js and browser_responsivecomputedview.js | Test timed out followed by Found a tab after previous test
Ported the openInspector/RuleView/ComputedView functions from styleinspector/test/head.js to the responsivedesign/test/head.js to get rid of this race condition.

Try push: https://tbpl.mozilla.org/?tree=Try&rev=60d9009707f1
Attachment #8408194 - Flags: review?(mratcliffe)
Attachment #8408194 - Flags: review?(mratcliffe) → review+
Just added utf-8 encoding to the test markup.
Green try.
Fixed in fx-team: https://hg.mozilla.org/integration/fx-team/rev/6d1315e1a026
Attachment #8408194 - Attachment is obsolete: true
Attachment #8408845 - Flags: review+
Whiteboard: [fixed-in-fx-team]
(In reply to TBPL Robot from comment #230)
> Tomcat
> https://tbpl.mozilla.org/php/getParsedLog.php?id=38074762&tree=Fx-Team
> Windows 7 32-bit fx-team pgo test mochitest-devtools-chrome on 2014-04-18
> 00:38:58
> revision: 8f2f17f5ab23
> slave: t-w732-ix-102
> 
> TEST-UNEXPECTED-FAIL |
> chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/
> browser_responsiveruleview.js | Test timed out
> TEST-UNEXPECTED-FAIL |
> chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/
> browser_responsiveruleview.js | Found a tab after previous test timed out:
> data:text/html,<html><style>div%20{%20%20width:%20500px;%20%20height:%2010px;
> %20%20background:%20purple;}%20@media%20screen%20and%20(max-width:
> %20200px)%20{%20%20div%20{%20%20%20%20%20width:%20100px;%20%20}};</
> style><div></div></html>
> Return code: 1
This fx-team build doesn't have my patch yet.
https://hg.mozilla.org/mozilla-central/rev/6d1315e1a026
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 31
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.