If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Composer alters textarea element

VERIFIED DUPLICATE of bug 73605

Status

()

Core
Editor
P2
major
VERIFIED DUPLICATE of bug 73605
17 years ago
16 years ago

People

(Reporter: rubydoo123, Assigned: Kathleen Brade)

Tracking

Trunk
mozilla0.9.2
All
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [html])

(Reporter)

Description

17 years ago
original code:
<textarea name="textarea test" rows=6 cols=30>TEXTAREA element</textarea>

code genreated by Composer:
<textarea defaultvalue="TEXTAREA element" value="TEXTAREA element" 
name="textarea test" rows="6" cols="30"></textarea>

from section 17.7 of the 4.01 DTD:
<!ELEMENT TEXTAREA - - (#PCDATA)       -- multi-line text field -->
<!ATTLIST TEXTAREA
     %attrs;                              -- %coreattrs, %i18n, %events --
     name        CDATA          #IMPLIED
     rows        NUMBER         #REQUIRED
     cols        NUMBER         #REQUIRED
     disabled    (disabled)     #IMPLIED  -- unavailable in this context --
     readonly    (readonly)     #IMPLIED
     tabindex    NUMBER         #IMPLIED  -- position in tabbing order --
     accesskey   %Character;    #IMPLIED  -- accessibility key character --
     onfocus     %Script;       #IMPLIED  -- the element got the focus --
     onblur      %Script;       #IMPLIED  -- the element lost the focus --
     onselect    %Script;       #IMPLIED  -- some text was selected --
     onchange    %Script;       #IMPLIED  -- the element value was changed --
     >

1. it strips the content of the textarea
2. it adds an illegal attribute 'defaultvalue'
3. it adds an illegal attribute 'value'
(Reporter)

Updated

17 years ago
Severity: normal → major
Keywords: correctness
Priority: -- → P2
Whiteboard: [html]
Target Milestone: --- → mozilla0.9.2
(Assignee)

Updated

17 years ago
Depends on: 17003
(Assignee)

Comment 1

17 years ago


*** This bug has been marked as a duplicate of 73605 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.