Crash Signature is missing a white space when I execute "Report this bug" from Mozilla Crash Reports page.

RESOLVED INVALID

Status

Socorro
General
--
minor
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Crash Signature is missing a white space when I execute "Report this bug" from Mozilla Crash Reports page.

It becomes problem of "Related Bugs" in the Mozilla Crash Reports page.

Steps to reproduce:
1. Crash browser with Crash Signature (ex. https://bugzilla.mozilla.org/show_bug.cgi?id=825446)
2. Open detail from about:crashes (ex.  bp-bb778e99-ed7e-4d76-92de-7142e2121229 )
3. Click one of link from "Report this bug in Firefox, Core, Plug-Ins, or Toolkit"
4. Observe text in "Crash Signature:" textbox

Actual results:
[@ _VEC_memcpy | mozilla::gfx::CopyDataToCairoSurface]

Expected results:
[@ _VEC_memcpy | mozilla::gfx::CopyDataToCairoSurface ]

i.e.
There should be a white space before ].

Comment 1

6 years ago
That whitespace should be irrelevant anyhow.

Comment 2

5 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #1)
> That whitespace should be irrelevant anyhow.

What is the spec?
Does the "spec" require whitespace"?

If yes, then crash bug titles should *add* it, whereas now it does not. For example 
   <title>  [@ _VEC_memcpy | mozilla::gfx::CopyDataToCairoSurface] - Firefox 17.0.7esr Crash Report - Report ID: e9677b4f-3f29-448d-a664-46ca72131105
</title>

If no, then the heading above the line "ID: e9677b4f-3f29-448d-a664-46ca72131105" should *remove* it. Currently, it shows as
"Firefox 17.0.7esr Crash Report [@ _VEC_memcpy | mozilla::gfx::CopyDataToCairoSurface ]"
Severity: normal → minor
Flags: needinfo?(chris.lonnen)

Comment 3

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #2)
> What is the spec?

The spec is the current implementation in Socorro.

> Does the "spec" require whitespace"?

No.

Comment 4

5 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #3)
> (In reply to Wayne Mery (:wsmwk) from comment #2)
> > What is the spec?
> 
> The spec is the current implementation in Socorro.

https://github.com/mozilla/socorro/blob/master/socorro/cron/jobs/bugzilla.py#L171  indeed, per lars

> > Does the "spec" require whitespace"?
> 
> No.

Thanks. Why then your addition of a space in https://bugzilla.mozilla.org/show_activity.cgi?id=323331 with your Cc: as the only other change?
Flags: needinfo?(kairo)

Comment 5

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #4)
> Thanks. Why then your addition of a space in
> https://bugzilla.mozilla.org/show_activity.cgi?id=323331 with your Cc: as
> the only other change?

Because based on experience sometimes adding or removing a space there caused that code to re-trigger its parsing and magically make things work (without knowing exactly why)
Flags: needinfo?(kairo)

Comment 6

5 years ago
There is no spec, as such, just what is in the cron. You can have a look yourself if you're curious: https://github.com/mozilla/socorro/blob/master/socorro/cron/jobs/bugzilla.py#L167

The parsing code doesn't care if a space is preceding the closing ']'.
Flags: needinfo?(chris.lonnen)

Comment 7

5 years ago
Gioven comment #6 and previous observations, I'm calling this invalid as there is no bug there.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.