Over invalidation on page causes janks and high CPU usage

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Mayank Bansal, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

292.09 KB, application/octet-stream
Details
(Reporter)

Description

6 years ago
Created attachment 696679 [details]
complete web page

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121230 Firefox/20.0
Build ID: 20121230030830

Steps to reproduce:

1. Create a fresh profile
2. Enable debug paint flashing
3. Go to http://onlyssd.com/ssd-brand/buy-crucial-ssd
4. Click anywhere on the page.    Snow will start dropping from the sky.



Actual results:

1.Each snow particle causes huge invalidations.
2.If possible, check CPU usage. It uses 100% of one core.
3. Try scrolling. Full page invalidation.


Expected results:

Less CPU usage. less invalidation. More page responsivity.


*************************************************
Attaching the complete page HTML.
This page is somewhat similar to the "IE10 bubbles demo".
(Reporter)

Comment 1

6 years ago
Also, FWIW, the falling snowflakes fall faster in FF15, Opera12.12 and IE10RC, as compared to the latest Nightly.
Component: Untriaged → Layout
Product: Firefox → Core
(Reporter)

Updated

5 years ago
Summary: Over invalidation on http://onlyssd.com/ssd-brand/buy-crucial-ssd → Over invalidation on page causes janks and high CPU usage
(Reporter)

Comment 2

5 years ago
The page seems to have removed the offending script, so to reproduce, see the attached complete webpage.
(Reporter)

Comment 3

4 years ago
Only the individual snow particles repaint now. And the heading in the top also repaints a lot.
The rest of the page doesnt repaint. However, the CPU use is still 100%

Comment 4

4 years ago
testcase URL fails http://www.onlyssd.com/ssd-brand/buy-crucial-ssd
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

4 years ago
I have attached the complete webpage as an attachment here.  The snowflakes will take 10-12 seconds to appear, and are not clearly visible. But they do affect the performnace.
  
On the latest nightly with a fresh profile, this page still causes heavy janks while scrolling, and opening menus etc.
I could not verify whether there is overinvalidation or not.

I am tentatively reopening this bug. Please do check the attached webpage.  If you dont find anything actionable, feel free to close this.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 6

4 years ago
I never see the snowflakes, and performance in IE and chrome are far worse.

Does it reproduce for you in safe mode?
Flags: needinfo?(mayankleoboy1)
(Reporter)

Comment 7

4 years ago
If you see debug paint flashing from the dev toolbar, you will see the snowflakes on the screen.

The invalidation problem is much better now. Each snowflake repaints only a very minimal amount.  However, the page is laggy in scrolling, and the menus take a long time to appear.

The problem is better in safe mode. So probably a gfx issue?
Flags: needinfo?(mayankleoboy1)

Updated

4 years ago
Component: Layout → Graphics

Comment 8

3 years ago
404 page not found :/
(Reporter)

Comment 9

3 years ago
cant repro anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.