Title Bar is missing, so double clicking upper left corner does NOT close window

RESOLVED DUPLICATE of bug 814571

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 814571
5 years ago
5 years ago

People

(Reporter: christoph.engelhardt, Unassigned)

Tracking

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11

Steps to reproduce:

Double clicked the upper left corner of the main window

Version: Thunderbird 17 latest
OS: Windows 7 x64 - all updates and service packs



Actual results:

The window switches between maximized and normal state. 
Same behaviour as double clicking the middle of the menu bar


Expected results:

Window closes - as is the Windows UI expected behaviour for this action
The titlebar is hidden by default in TB 17. You can enable it by setting mail.tabs.drawInTitlebar to true in the advanced configuration options

For more detailed instructions, see http://superuser.com/questions/508281/how-do-i-restore-the-caption-to-thunderbird-17s-title-bar
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

5 years ago
Hi David, 
Thanks for taking the time to update this bug and lending me some help. 

Don't get me wrong here, after all this is your application and you are free to do with it, whatever you like. 

That being said, I think that providing the expected behaviour is an essential part of good UX and I find thunderbird is lacking in this regard. In previous versions the hit target to close Thunderbird was gigantic: Just throw your mouse all the way up and to the left. 
Thunderbird is an otherwise great application, I really love it. So I want to make it even better.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

5 years ago
A few other people have expressed your level of interest. But there is no sign of going back.  Window closing "X" is now in top right. The current UI/behavior and mail.tabs.drawInTitlebar settings/workaround is intentional, per australis design. So David is correct in closing this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → INVALID
Summary: Double clicking upper left corner does NOT close window → Title Bar is missing, so double clicking upper left corner does NOT close window

Updated

5 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 814571
You need to log in before you can comment on or make changes to this bug.