Closed Bug 825576 Opened 8 years ago Closed 8 years ago

Update clang (manifest) for OS X (use clang 3.2 final version, port Bug 823906)

Categories

(SeaMonkey :: Build Config, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mcsmurf, Assigned: Callek)

Details

Attachments

(3 files, 2 obsolete files)

I'm not sure if we need to do this, too: Firefox and Thunderbird updated their clang manifests (suite/config/tooltool-manifests/macosx* in our case) to use a newer clang 3.2 branch version. I've noticed that the "make check" test of the OS X 64 tinderbox on trunk fails:
cppunittests TEST-UNEXPECTED-FAIL | transport_unittests | test crashed

The clang update revision comment on TB says something about fixing make check failures with this newer clang version, see http://hg.mozilla.org/comm-central/rev/ec9f4a50e3b4
Attached patch Patch (obsolete) — Splinter Review
Justin: I'm not sure how exactly clang is updated. Is it just a matter of copying over those clang binaries from the MoCo server to the webserver that can be accessed by the SeaMonkey build slaves (and pushing this patch)?
Attachment #696696 - Flags: review?(bugspam.Callek)
Comment on attachment 696696 [details] [diff] [review]
Patch

Actually, this is not the latest clang version, FF has a newer one.
Attachment #696696 - Flags: review?(bugspam.Callek)
Attached patch Patch (obsolete) — Splinter Review
This one is the latest version, see http://hg.mozilla.org/mozilla-central/filelog/0d771761b9b3/browser/config/tooltool-manifests/macosx64/releng.manifest
Attachment #696696 - Attachment is obsolete: true
Attachment #696697 - Flags: review?(bugspam.Callek)
Summary: Update clang (manifest) for OS X? → Update clang (manifest) for OS X (use clang 3.2 final version, port Bug 823906)
Assignee: nobody → bugspam.Callek
Status: NEW → ASSIGNED
Attachment #696699 - Flags: review?(bugzilla)
Comment on attachment 696697 [details] [diff] [review]
Patch

I'm r-'ing for three reasons

(a) we midaired, and the ver I added is what I for-sure added to the tooltool we have access to
(b) mac32 is unused now for our [successful] builds.
(c) even though its unused by default, my patch changes the linux versions too.
Attachment #696697 - Flags: review?(bugspam.Callek) → review-
(In reply to Frank Wein [:mcsmurf] from comment #1)
> Created attachment 696696 [details] [diff] [review]
> Patch
> 
> Justin: I'm not sure how exactly clang is updated. Is it just a matter of
> copying over those clang binaries from the MoCo server to the webserver that
> can be accessed by the SeaMonkey build slaves (and pushing this patch)?

Indeed, and when you filed this I was already thinking that we should update, so I *just* copied over all current clang binaries to our public server.
Do it for aurora too

[Approval Request Comment]
Regression caused by (bug #): none
Testing completed (on m-c, etc.): This matches Firefox compiling
Risk to taking this patch (and alternatives if risky): very very low
String changes made by this patch: None
Attachment #696697 - Attachment is obsolete: true
Attachment #696700 - Flags: review?(bugzilla)
Attachment #696700 - Flags: approval-comm-aurora?
[Approval Request Comment]
Regression caused by (bug #): none
Testing completed (on m-c, etc.): This matches Firefox compiling
Risk to taking this patch (and alternatives if risky): very very low
String changes made by this patch: None
Attachment #696701 - Flags: review?(bugzilla)
Attachment #696701 - Flags: approval-comm-beta?
Attachment #696700 - Flags: approval-comm-aurora? → approval-comm-aurora+
Comment on attachment 696701 [details] [diff] [review]
[beta] ..and finally beta

rs=me
Attachment #696701 - Flags: approval-comm-beta? → approval-comm-beta+
Attachment #696699 - Flags: review?(bugzilla) → review+
Attachment #696700 - Flags: review?(bugzilla) → review+
Comment on attachment 696701 [details] [diff] [review]
[beta] ..and finally beta

mozilla-central still uses r161152. So I'd rather not update here as usually regressions due to compiler change are discovered earlier on mozilla-central/Firefox.
Comment on attachment 696701 [details] [diff] [review]
[beta] ..and finally beta

Nevermind, looks like comm-beta MXR is out-of-date (mozilla-beta MXR is ok).
Attachment #696701 - Flags: review?(bugzilla) → review+
https://hg.mozilla.org/comm-central/rev/cf44b65f2bf6
https://hg.mozilla.org/releases/comm-aurora/rev/0f5a7fd7a87c
https://hg.mozilla.org/releases/comm-beta/rev/4816e242a4b6

Accidentally marked mcsmurf as approver in checkin message
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.