sessionrestore disappears intermittently

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: mayankleoboy1, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121230 Firefox/20.0
Build ID: 20121230030830

Steps to reproduce:

1. create a fresh profile/ used profile.
2. type about:config in URL bar
3. enable the preference   nglayout.debug.paint_flashing  to TRUE
4. Open 3-4 tabs and load some URL's. even google will do
5. Close Nightly.
6. Restart Nightly
7.try to "restore previous session".


Actual results:

The "restore previous session" is blank.  So you cant restore the previous session.
Now type "about:sessionrestore" in URL bar.  It is empty.


Expected results:

can restore session.
(Reporter)

Comment 1

6 years ago
I dont think its due to this preference :(

Its been intermittent.  Earlier i was able to repro this on a fresh/used profile with this preference multiple times.

Now this pref has no effect. But my main profile just lost the session restore. I disabled all extensions. Sessionrestore was restored.
But enabling all extensions does not cause the bug now.
Summary: enabling nglayout.debug.paint_flashing causes sessionrestore to disappear → sessionrestore disappears intermittently
(Reporter)

Comment 2

6 years ago
Cant reproduce this now. So marking Worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.