Closed Bug 825682 Opened 10 years ago Closed 10 years ago

If form field values have accented characters, form submission during bank account creation fails

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME
2013-01-17

People

(Reporter: krupa.mozbugs, Assigned: basta)

References

Details

(Whiteboard: u=dev c=pmt p=1)

steps to reproduce:
1. Using a newly created account, submit a paid app
2. Click on "Set up Payments" after completing submission
3. In Compatibility & Payments page, click on Add Account
4. In the form fields enter the value "Javier Ángel Encinas Bardem" for Account Holder name, Vendor name, Company Name and Account name fields.

expected behavior:
We support all unicode characters especially characters with accents since they are common in Spanish and Portuguese.

observed behavior:
Form submission fails with "Could not connect to payment server."
Dec 31 14:40:28 dev2.addons.phx1.mozilla.com: [1df0320c-8a69-11e1-bf36-441ea15c3000][69.172.162.140] z.devhub:ERROR Error creating Bango payment account; There was an error with that request. :/data/www/addons-dev.allizom.org/zamboni/mkt/developers/views_payments.py:145

Is all we've got in the zamboni log. Can we get something a bit more verbose? Or just raise an 500 error? Assigning to basta for adding verbosity.
Assignee: nobody → mattbasta
I agree. Please raise any and all exceptions that have to do with talking to Solitude. We should not catch and log them because if an exception occurs there is no way to recover. We want to be alerted immediately of exceptions.
Every time we catch client.Error, it's being raised. Please try to reproduce now.
I'm getting: http://sentry.dmz.phx1.mozilla.com/marketplace-dev/group/10664/

Which is a 400: {'seller': ('Not a valid resource.',)} which I thought we had elsewhere...
Summary: If form field values have accented characters form submission during bank account creation fails → If form field values have accented characters, form submission during bank account creation fails
Priority: -- → P3
Whiteboard: u=dev c=pmt p=1
Target Milestone: --- → 2013-01-10
Target Milestone: 2013-01-10 → 2013-01-17
This seems to have been fixed. It's no longer reproducible using the string in comment 0 (I pasted it into each of the fields). This was either a.) fixed by something else or b.) a different bug which surfaced in this way. I'm leaning towards the latter, so keep your eyes peeled for payment accounts-related bugs.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.