[B2G][Homescreen] Swiping animation only shows last frame

RESOLVED FIXED in Firefox 21

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: kanru, Assigned: kentuckyfriedtakahe)

Tracking

unspecified
mozilla21
All
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:tef+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed, b2g18-v1.0.0 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

6 years ago
Possible regression from bug 780692

As found in bug 822721 comment #30, turning off throttling will make the animation smooth again.
Blocks: 780692
This doesn't happen on b2g18 (not sure about aurora), so it's some difference between those two codebases.

Comment 2

6 years ago
Changeset 116956:955a8b88d796 might be the cause(not yet in b2g18).

changeset:   116956:955a8b88d796
user:        Anthony Jones <ajones@mozilla.com>
date:        Sun Dec 23 10:50:04 2012 -0500
summary:     Bug 811950 - Fix async scrolling of position:fixed. r=cjones
Blocks: 811950
No longer blocks: 780692
Duplicate of this bug: 827211
Created attachment 700844 [details] [diff] [review]
Fix animations by marking transforms as not fixed
Assignee: nobody → ajones
Status: NEW → ASSIGNED
Attachment #700844 - Flags: review?
Attachment #700844 - Attachment is obsolete: true
Attachment #700844 - Flags: review?
Created attachment 700847 [details] [diff] [review]
Fix animations by marking transforms as not fixed v2
Attachment #700847 - Flags: review?(roc)
Comment on attachment 700847 [details] [diff] [review]
Fix animations by marking transforms as not fixed v2

Review of attachment 700847 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/ipc/CompositorParent.cpp
@@ +817,5 @@
>          matrix.ScalePost(c->GetInheritedXScale(),
>                           c->GetInheritedYScale(),
>                           1);
>        }
> +      NS_ASSERTION(!aLayer->GetIsFixedPosition(), "Can't animate fixed layers");

"Can't animate transforms on fixed-position layers"

::: layout/base/FrameLayerBuilder.cpp
@@ +2170,5 @@
>          ownLayer->SetPostScale(mParameters.mXScale,
>                                 mParameters.mYScale);
>        }
>  
> +      ownLayer->SetIsFixedPosition(isFixed && type != TYPE_TRANSFORM);

Add a comment indicating why we're doing this (layers can't support transforms and fixed-pos at the same time).
Attachment #700847 - Flags: review?(roc) → review+

Comment 7

6 years ago
Try run for 26e2053b29f7 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=26e2053b29f7
Results (out of 101 total builds):
    exception: 1
    success: 84
    warnings: 4
    failure: 12
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-26e2053b29f7

Comment 8

6 years ago
Try run for 163a0f4c28bd is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=163a0f4c28bd
Results (out of 304 total builds):
    exception: 1
    success: 270
    warnings: 25
    failure: 8
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-163a0f4c28bd
Created attachment 701399 [details] [diff] [review]
Fix animations by marking transforms as not fixed v3

Carrying over r+
Attachment #700847 - Attachment is obsolete: true

Comment 11

6 years ago
Try run for f857e1dc8808 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=f857e1dc8808
Results (out of 20 total builds):
    success: 20
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-f857e1dc8808
Was it intentional that this doesn't have any flags for b2g18?
Comment on attachment 701399 [details] [diff] [review]
Fix animations by marking transforms as not fixed v3

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 811950
User impact if declined: Animations get broken if we allow marking of shadow layers as fixed; blocks 811950
Testing completed: Tested home screen and nzherald.co.nz
Risk to taking this patch (and alternatives if risky): Low risk. Transforms are not usually fixed.
String or UUID changes made by this patch: None
Attachment #701399 - Flags: approval-mozilla-b2g18?
https://hg.mozilla.org/mozilla-central/rev/c9ab471450fa
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21

Updated

6 years ago
blocking-b2g: --- → tef+
blocked a tef+ bug. See https://bugzilla.mozilla.org/show_bug.cgi?id=811950#c27 for an explanation.
Attachment #701399 - Flags: approval-mozilla-b2g18?
https://hg.mozilla.org/releases/mozilla-b2g18/rev/88e48fb94cde
status-b2g18: --- → fixed
status-firefox19: --- → wontfix
status-firefox20: --- → wontfix
status-firefox21: --- → fixed
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
status-b2g18-v1.0.0: --- → fixed
You need to log in before you can comment on or make changes to this bug.