"User Guide" link in Settings app always points to en-US URL

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: timdream, Assigned: julienw)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

Summary: "User Guide" link in Settings app always points to en-US URLs → "User Guide" link in Settings app always points to en-US URL
Could I take over the issue?
(Assignee)

Updated

6 years ago
Assignee: nobody → felash
(In reply to Ian Liu [:ianliu] from comment #2)
> Could I take over the issue?

You don't really need to ask before taking a nobody's bug.
(Assignee)

Comment 4

6 years ago
The link points to a wrong URL but it still displays in french when the phone is configured in French, so I think the redirection works even with this complicated link.

I'll still provide a patch to make this code simpler.
(Assignee)

Comment 5

6 years ago
Created attachment 697003 [details] [diff] [review]
patch v1

Always use the unlocalized URL for the user guide.
Attachment #697003 - Flags: review?(kaze)
Comment on attachment 697003 [details] [diff] [review]
patch v1

Review of attachment 697003 [details] [diff] [review]:
-----------------------------------------------------------------

::: apps/settings/js/settings.js
@@ +449,5 @@
>    },
>  
>    getUserGuide: function settings_getUserGuide(callback) {
> +    var url = 'http://support.mozilla.org/products/firefox-os';
> +    callback(url);

I can’t find the relevant bmo entry but I’m pretty sure the FxOS version is required in this URL.
Comment on attachment 697003 [details] [diff] [review]
patch v1

I’m not sure the URL is correct but I’ll rely on this approach:
https://bugzilla.mozilla.org/show_bug.cgi?id=823057#c13
Attachment #697003 - Flags: review?(kaze) → review+
(Assignee)

Comment 8

6 years ago
https://github.com/mozilla-b2g/gaia/commit/c95ae8a647decfddb225b786216bb6154acecb8e
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 9

6 years ago
Kaze, is anyone on this bug that could follow-up on that url, if it was sad-making?
Axel: sure, feel free to ping me in case we need a quick fix.
Sorry we didn't catch this earlier, but we (Support) need the URL with the product version and the other details in it, as defined in bug 799786. Also, comment #4 seems to indicate there was no issue with the original link to begin with. The link was a bit complicated for a reason ;)

What are our options here? Can we just revert this commit?

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

6 years ago
This is way too old, please file a new bug, that will be easier.

I still think the "locale" part should be handled by the server, though...
(Assignee)

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.