add-on validation on addons.mozilla.org is failing with a 500 error

RESOLVED WORKSFORME

Status

--
blocker
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: jik, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 697005 [details]
error trying to validate add-on

I get a 500 error when I try to upload a new version of the Send Later add-on. "Received an empty response from the server; status 500". See attached screen capture.
Please attach the XPI you get this error with.
(Reporter)

Comment 2

6 years ago
Created attachment 697006 [details]
XPI causing the 500 error
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

6 years ago
That traceback looks like an error with Rabbit/celery, not the validator. Is this problem consistently reproducible or is it a sporadic problem?
(Reporter)

Comment 5

6 years ago
It was failing consistently for me this morning but just worked when I tried it again.
We had a hardware issue with one of the nodes in our rabbitmq cluster earlier today during this bug's reported time (bug 778068 comment 56). This was resolved as of 6:20AM PDT. Bug 825938 to upgrade rabbitmq to latest version for better ha queue support.

Comment 7

6 years ago
Cool, thanks for the feedback.

Jonathan: Please let us know if you continue to have problems. If you're getting similar errors, get in contact with an AMO editor and they can override the validation step for you.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.