{sink} [JavaScript?] Navigation links are dead on www.wbmovies.com

VERIFIED FIXED in M11

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Eli Goldberg, Assigned: vidur (gone))

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [990916] Need minimal test case for document[n].prop failure, URL)

(Reporter)

Description

19 years ago
* TITLE/SUMMARY
[JavaScript?] Navigation links are dead on www.wbmovies.com

[broken out of 927]

* STEPS TO REPRODUCE
0) Launch Apprunner
1) View http://www.wbmovies.com/main.html (or, http://bugzilla.mozilla.org/
showattachment.cgi?attach_id=382 for the left-hand frame, with the mouseover
JavaScript fixed.)
2) Attempt to click on any of the links (e.g. New releases, Classic sites, etc)

* RESULT
 - What happened

The mouse pointer correctly changes to a hand upon being on top of the image.

Sometimes, all of the images are replaced with blank spacer rectangles upon
clicking.

Otherwise, nothing.

 - What was expected

For the wbmovies.com/main.html page, the browser should display the page in
question.

For Bugzilla attachment #382 [details], a not found link (relative link that doesn't work,
of course, within bugzilla.mozilla.org)

I note that the c() function invoked upon an onclick event, BTW, is browser-
specific, should it matter, and AFAIK.

* REGRESSION

 - Occurs On
        Mac OS Apprunner (6.15.99 PM optimized build)
        Win32 Apprunner (6.14.99 AM optimized build [NT 4, Service Pack 3])
        Linux Apprunner (6.14.99 AM optimized build)

 - Doesn't Occur On
        Mac OS Communicator 4.6 (RTM)

* CONFIGURATIONS TESTED

- [Mac] Power Mac 8500/120 (233 Mhz 604e), 64 MB RAM (VM on; 1 MB of VM used),
1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 Mhz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP3.

- [Linux] Vectra VL (266 Mhz P2), 96 MB RAM.


* TOKEN DISCLAIMER

Sorry, no decomposition. Unlike gurus like Prashant, the JavaScript on this page
is over my little head.

Updated

19 years ago
QA Contact: cbegle → gerardok
(Reporter)

Updated

19 years ago
Blocks: 927

Updated

19 years ago
Assignee: mccabe → vidur
No longer blocks: 927
Component: Javascript Engine → DOM Level 0

Comment 1

19 years ago
Whatever bug this is, it's most likely not with the Javascript engine, which
just has to do with the mechanics of running scripts.  Most of the objects that
javascript manipulates, like 'window', aren't part of the javascript engine.
Hm.  Maybe the DOM...  (Sorry, Vidur.)

Eli - you've given excellent instructions on how to reproduce the bug, but it
might help a fix if we had some handle on what's going wrong.  Maybe you should
assign bugs of this sort to Prashant until they've been tied to something more
specific? :)
(Reporter)

Updated

19 years ago
QA Contact: gerardok → desale
(Reporter)

Comment 2

19 years ago
You're right, and I couldn't agree with you more; it's definitely not a
JavaScript Engine bug.

Unfortunately, while the "Components" list is clear that JavaScript Engine is the
wrong place to go, it gives no indication of what the *right* place is, resulting
in people like me continuing to send you bugs that really are someone else's
problem. ;)

It would be a huge help to QA if this information could be provided there, or in
a form that I could arrange to have placed there (if there's a straightforward
answer.)

QA Assigning to Prashant "The JavaScript Man" Desale.

Comment 3

19 years ago
I just went through this bug.
Elig, the Dude did really nice investigation on this bug. Links on this site
seem pretty dead. The reason why these links are dead because of use of
"target".
In actual site, provided by Elig, target="mainmovies" is used in links.

I simulated the problem.

STEPS TO REPRODUCE:

1] Visit URL http://bubblegum/desale/bug8259/bug8259.html [Here I'm using
target="_new"]
2] It will show you 6 navigation buttons on upper-left corner.
3] Click any of those navigation buttons.

EXPECTED RESULTS:
On clicking those buttons, it should open another window [Since target="_new"]
to take you to that link.

ACTUAL RESULTS:
Nothing happens. Links seem pretty dead.

DESFCRIPTION:

1] Now visit URL http://bubblegum/desale/bug8259/tempbug8259.html [Here I'm not
using target.] So supposed to work fine.
2] It will show you 6 navigation buttons on upper-left corner.
3] Click any of those navigation buttons.

EXPECTED RESULTS:
On clicking those buttons, it take you to appropriate link.

ACTUAL RESULTS:
This time you'll see "File not found", That means its working. Link is not dead.

So this use of target in links is causing the problem.

Builds I used are 1999-06-16-08.
(Reporter)

Updated

19 years ago
Blocks: 927
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
Based on attachment 382 [details], I am marking this WORKSFORME.  Clicking on the link
"New releases" in that attachment opens a new window in both viewer and
apprunner.

I can't test the internal pages on bubblegum.  Whoever verifies should check
those.

I'm tested on viewer and apprunner, Linux, 1999-09-03-11-M11

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 5

19 years ago
May be its not problem with target anymore, but bug seems still be there.
If we visit URL "http://www.wbmovies.com/main.html" and try to click buttons [In
left frame] like "New Relases", "Classic Sites", those links seem pretty dead.

I did some investigation on this, and looks like there is some problem with
document[num] array. This is used in js functions of the site provided above.

I'm providing testcase to explain that there is something wrong with
document[num] array.

BUILDS: 09-07-09.

I Tested with Win-95.

STEPS TO REPRODUCE:
1] Please copy HTML code I'm providing. Save it as HTML file and oopen this file
in apprunner as well as viewer.

EXPECTED RESULTS:
You should see the blan images on screen and

document[0].src=zero.gif
document[1].src=one.gif
document[2].src=two.gif

ACTUAL RESULTS:
Three blank images and

document[2].src=two.gif

DESCRIPTION:
What happend to first two images in array. I'm simply using
document.write(document[num].src); to write source files name on screen for all
three images.
If I use two images, then it only shows last image. It ignores whatever is
before last image. It displays only last image source.
Something could be wrong with that array.

CODE:

<html>
<head>
<title>Test Page</title>
</head>
<body>
<table width=118 cellpadding=0 cellspacing=0 border=0>
<tr>
<td valign=top align=right>
<a href="javascript:void()" ><img src="zero.gif" name="0"></a><br>
<a href="javascript:void()" ><img src="one.gif"  name="1"></a><br>
<a href="javascript:void()" ><img src="two.gif"  name="2"></a><br>
</td></tr></table>
<script>
<!--
document.write("document[0].src=");
document.write(document[0].src);
document.write('<br>');
document.write("document[1].src=");
document.write(document[1].src);
document.write('<br>');
document.write("document[2].src=");
document.write(document[2].src);
//-->
</script>
</body>
</html>

END OF CODE:

Right now I'm reopening this bug, and main reason is, links in site mentioned
are still dead. Whatever my conclusion, why those are dead could be wrong, but
thats what I think right now that something is wrong with document[num] array.
Whiteboard: [990916] Need minimal test case for document[n].prop failure
Target Milestone: M11
Looking at this bug now, I notice that if I put:

  document.write("<p>");

before

  document.write("document[0].src=");
  document.write(document[0].src);
  // ...

then I get all the correct output[*].  So there's a document.write bug here,
perhaps, but document[num] appears to be working to order.

[*]
document[0].src=zero.gif
document[1].src=one.gif
document[2].src=two.gif

And yet, the page in question doesn't work.  Someone should develop a minimal
test case that shows this problem in action, and attach it here.  There's too
much going on on that page to debug effectively.

(The test case above doesn't fail the same way, or the document[0].src
references would give errors.)

Can you do that, Prashant?

I think this _is_ a beta issue, so the sooner we can get this test case the
better.
(Assignee)

Comment 7

19 years ago
The document.write problem is probably related to 11141 and should be fixed for
beta 1.

Comment 8

19 years ago
I'm trying to narrow down the problem. As soon as I create new testcase I'm
gonna post it.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
Summary: [JavaScript?] Navigation links are dead on www.wbmovies.com → {sink} [JavaScript?] Navigation links are dead on www.wbmovies.com
(Assignee)

Comment 9

19 years ago
My sink changes from earlier this week seem to have fixed the dead links
problem.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
Tested with 1999-11-04-09, Working fine. Marking verified.
You need to log in before you can comment on or make changes to this bug.