First Time Experience WiFi connection screen prints status keywords (e.g. "connectingfailed") rather than localized human-readable strings



Firefox OS
Gaia::First Time Experience
5 years ago
5 years ago


(Reporter: dholbert, Unassigned)


({b2g-testdriver, late-l10n, unagi})

Gonk (Firefox OS)
b2g-testdriver, late-l10n, unagi

Firefox Tracking Flags





5 years ago
 1. Start first time experience 
 2. At WiFi screen, pick a password-protected network (I tried both WPA and WEP)
 3. When prompted, type in the wrong password, and click "join"
 4. Watch the connection status as it tries to join

 Status starts out as "connecting", which may flicker a bit as it retries, and eventually changes to "connectingfailed" (all one word), and then finally "disconnected"

EXPECTED RESULTS: "connectingfailed" should have a space (or be replaced with just "failed" or something -- not two words smooshed together)

Comment 1

5 years ago
This doesn't affect the Settings app itself -- there, it says "Connecting..." capitalized, with ellipsis, and then either "Connection failed" or (more frequently) it just goes back to "Secured by WPA-PSK".

So: This bug (printing "connectingfailed") only affects the First Time Experience wifi connection page, AFAICT.

Build ID: 20121226070202

Comment 2

5 years ago
Note that this means we're apparently using a different string (un-capitalized "connecting") on the First Time Experience page, as compared to the actual WiFi settings app (capitalized "Connecting")... Not sure why we'd be doing that.

Comment 3

5 years ago
I think the issue is that we're printing the status keyword (which is supposed to be converted into a localized string, but isn't currently).

The status keywords are listed here, and I think I've seen them all printed in the FTU before:
* - connecting:
* fires when we start the process of connecting to a network.
* - associated:
* fires when we have connected to an access point but do not yet
* have an IP address.
* - connected:
* fires once we are fully connected to an access point.
* - connectingfailed:
* fires when we fail to connect to an access point.
* - disconnected:
* fires when we were connected to a network but have been
* disconnected.

Comment 4

5 years ago
Adding late-l10n, though it might not be too bad because we presumably have all the required strings already (and we're just not using them) in the FTU app and/or in the WiFi app.
Keywords: late-l10n
Summary: On First time experience Wi-Fi screen, if you type the wrong WPA or WEP password, it says "connectingfailed" (all one word) → First Time Experience WiFi connection screen prints status keywords (e.g. "connectingfailed") rather than localized human-readable strings

Comment 5

5 years ago
Looks like the strings that are _supposed to_ be displayed here are all there, so hopefully there aren't actually any l10n changes required -- we just need to hook things up so the strings are actually displayed.

The strings are here:
shortStatus-connecting = Connecting…
shortStatus-associated = Obtaining an IP address…
shortStatus-connected = Connected
shortStatus-connectingfailed = Connection failed
shortStatus-disconnected = Offline


5 years ago
Component: Gaia → Gaia::First Time Experience
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM

Comment 6

5 years ago
Actually, looks like bug 824457 made some changes here in the last few days, though the reported issue there was a bit different.  Alive, do you know if that bug's changes would've fixed this as well?
Flags: needinfo?(alive)
Yes, I fixed this bug in my patch too. Please try with latest build :) I think FTU Wi-Fi is more user-friendly now.
Flags: needinfo?(alive)
Last Resolved: 5 years ago
Resolution: --- → FIXED


5 years ago
Depends on: 824457
blocking-basecamp: ? → -
Verified fixed in 2013-01-31-07-02-01 pvt nightly b2g18 build
You need to log in before you can comment on or make changes to this bug.