Remove apostrophe key from primary level of keyboard

RESOLVED FIXED

Status

Firefox OS
Gaia::Keyboard
--
minor
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Tyler, Assigned: rudyl)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme, [LOE:S], ux-tracking, ux-priority1.3)

(Reporter)

Description

5 years ago
The ' on the keyboard is very awkwardly placed. I always tend to hit it when typing, instead of hitting an L, and it is just odd being the only punctuation on the visible ABC keyboard (other than , Space and . but they are on the bottom row). Perhaps some better UX on the keyboard to either rearrange the punctuation keys or make this harder to hit by accident would be nice :) (A LA android's new keyboard)
Agreed 100%. This deviates from virtual and physical keyboard layout standards, going against the grain of user training and making accurate text entry of the entire middle row feel "off".

We already have an apostrophe on the special characters level of the keyboard.

Goal: remove apostrophe key from primary level of the keyboard, leave the position blank, and center the remaining keys of the middle row, leaving two small gaps on the left and right sides.
Summary: ' is Awkwardly placed → Remove apostrophe key from primary level of keyboard
Whiteboard: u=user c=keyboard s=ux-most-wanted
Rudy, is this something you can take a look at? We're hoping the LOE here is low.
Flags: needinfo?(rlu)
Rudy, I will provide a new layout for this. We want to make a few other size / position tweaks. Should be minor for LOE but help with usability.
Hi Josh,

Yes, I can tweak the layout.

[LOE]
LOE will be 1-2 days, since this also requires some changes on the CSS style, especially the key highlighting effect (we do some tricks for the highlighted key near the edge of the keyboard).

Thanks.
Assignee: nobody → rlu
Flags: needinfo?(rlu)
Whiteboard: u=user c=keyboard s=ux-most-wanted → u=user c=keyboard s=ux-most-wanted [LOE:S]
Thanks Rudy. I will email you the proposed revised layout. Let's wait on implementation until we confirm the performance discussions happening in bug #827811 (we may need to also change the layout for responsiveness reasons).
Blocks: 859189

Comment 6

5 years ago
(In reply to Josh Carpenter [:jcarpenter] from comment #5)
> Thanks Rudy. I will email you the proposed revised layout. Let's wait on
> implementation until we confirm the performance discussions happening in bug
> #827811 (we may need to also change the layout for responsiveness reasons).

Looks like there hasn't been any activity on bug #827811. I pinged Jed for an update.

Josh,
Did you send Rudy the revised layout?
Flags: needinfo?(jcarpenter)

Updated

5 years ago
Whiteboard: u=user c=keyboard s=ux-most-wanted [LOE:S] → [LOE:S], ux-tracking
Hi Josh, Francis,

Do we need to remove the last key in the second row from all the layouts of different languages? 
(apostrophe for English layout, 
 ñ for Spanish, etc.)

The latest IME reference UX doc I received from Josh was updated on April 17, 2013, which indicated that that part is not confirmed yet.
Do we have this updated?

Thanks.
Flags: needinfo?(fdjabri)
fdjabri@mozilla.com, jcarpenter, any new on this bug?
> Do we need to remove the last key in the second row from all the layouts of
> different languages? 
> (apostrophe for English layout, 
>  ñ for Spanish, etc.)
> 

Hi Rudy, 

In short answer to your question - no. The intent of this bug was to move the last character from keyboard layouts where it usually isn't present, and so interferes with people's muscle memory of where the keys are meant to be. We certainly shouldn't be removing the last character from the second row if that character is usually present in that location for that particular language. 

Based on a review of the main competitor keyboard layouts, this is the action that is needed for each keyboard layout:

English - remove apostrophe
Español - keep ñ character
Portuguese - remove ç character
Polski - remove : character
Česká - remove apostrophe
Francais - keep as it is
Deutsch - remove apostrophe
Norsk - keep as it is
Slovenčina - remove apostrophe
Turkish - remove apostrophe
Flags: needinfo?(jcarpenter)
Flags: needinfo?(fdjabri)

Updated

4 years ago
Whiteboard: [LOE:S], ux-tracking → [LOE:S], ux-tracking, ux-priority1.3
Depends on: 951190
Already removed?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [LOE:S], ux-tracking, ux-priority1.3 → dupme, [LOE:S], ux-tracking, ux-priority1.3
You need to log in before you can comment on or make changes to this bug.