[B2G] [SMS] Contacts : SMS message deleted when choosing contact for search or contact list

VERIFIED FIXED in B2G C4 (2jan on)

Status

Firefox OS
Gaia::SMS
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Misty Byrd, Assigned: borjasalguero)

Tracking

({late-l10n})

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)
late-l10n

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: interaction, UX-P2, BerlinWW)

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 697234 [details]
enter into message field before choosing contact

Perquisites:
1. Import fake contacts from UI tests
2. Add a new  contact

Steps to Reproduce: Previously typed message is deleted from text field when choosing a contact from search or contacts icon.

Steps to Reproduce:
1) Install Build 20130102070202 v.1 on an Unagi Device
2) Select SMS app
3.) Select + to open new SMS
4) Type Message in message field
5)  Type existing contact in search field/or select contact icon
6) Select a valid contact from the existing list 

Expected:
Contact added to field can send message
Repro frequency:
Repros 10/10 times

Actual:
When selecting an existing contact the message field that a previously typed message is deleted. Must retype message after selecting contact
(Reporter)

Comment 1

5 years ago
Created attachment 697235 [details]
screen shot step 2
(Reporter)

Comment 2

5 years ago
Created attachment 697236 [details]
step 3

Updated

5 years ago
Whiteboard: interaction [UX-P1]
Yikes, should definitely fix this. Adding "BerlinWW" for dev attention this week.
Whiteboard: interaction [UX-P1] → interaction, UX-P2, BerlinWW
(Assignee)

Updated

5 years ago
Assignee: nobody → fbsc
(Assignee)

Comment 4

5 years ago
Ok, I will come back with a patch!
(Assignee)

Comment 5

5 years ago
I've never realized of this issue, but it's horrible! We should update to BB+ because the user interaction it's so bad without the patch.
blocking-basecamp: --- → ?
(Assignee)

Comment 6

5 years ago
Created attachment 699284 [details]
PR
Attachment #699284 - Flags: review?(schung)
(Assignee)

Comment 7

5 years ago
Patch ready!
(Assignee)

Comment 8

5 years ago
Im gonna include some comments of Ayman, so the patch will be ready asap!
(Assignee)

Comment 9

5 years ago
Only thing to fix to the patch is the sentence that we are going to show to the user (i.e. 'Are you sure you want to discard this SMS?). Ayman, what will be the right one? Thanks!
Flags: needinfo?(aymanmaat)

Comment 10

5 years ago
(In reply to Borja Salguero [:borjasalguero] from comment #9)
> Only thing to fix to the patch is the sentence that we are going to show to
> the user (i.e. 'Are you sure you want to discard this SMS?). Ayman, what
> will be the right one? Thanks!

**text** 
are you sure you want to discard this message?

**2 CTAs** 
yes | no
Flags: needinfo?(aymanmaat)
(Assignee)

Updated

5 years ago
Blocks: 827889
(Assignee)

Updated

5 years ago
Attachment #699284 - Flags: review?(l10n)
Comment on attachment 699284 [details]
PR

Hi Borja, I've leave some comments on github. You can ask for the review again when you complete the fixing. Thanks.
Attachment #699284 - Flags: review?(schung)
blocking-basecamp: ? → +
Priority: -- → P2
Target Milestone: --- → B2G C4 (2jan on)
(Assignee)

Updated

5 years ago
Attachment #699284 - Flags: review?(schung)
(Assignee)

Comment 12

5 years ago
Comment on attachment 699284 [details]
PR

Im gonna add Kaze to l10n review as well.
Attachment #699284 - Flags: review?(kaze)
Comment on attachment 699284 [details]
PR

r=me for the l10n part
Attachment #699284 - Flags: review?(kaze) → review+
Keywords: late-l10n
(Assignee)

Updated

5 years ago
Attachment #699284 - Flags: review?(l10n)

Updated

5 years ago
Attachment #699284 - Flags: review?(schung) → review+

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Verified fixed in 2013-01-25-07-02-01 pvt nightly b2g18 build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.