Don't restart emulator on socket.timeout

RESOLVED FIXED in Firefox 19

Status

Testing
Marionette
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jgriffin, Assigned: jgriffin)

Tracking

unspecified
mozilla20
Points:
---

Firefox Tracking Flags

(firefox19 fixed, firefox20 fixed, b2g18 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
We currently have code that tries to restart the emulator if a socket.timeout occurs, in order to automatically recover from some types of failures.  However, this doesn't work, and in fact causes other problems (see stack trace in bug 824079 for example).  We should just remove this code.
(Assignee)

Comment 1

5 years ago
Created attachment 697291 [details] [diff] [review]
Don't restart emulator on failure,
Attachment #697291 - Flags: review?(ahalberstadt)
(Assignee)

Comment 2

5 years ago
Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=613f76889f7a
Comment on attachment 697291 [details] [diff] [review]
Don't restart emulator on failure,

Review of attachment 697291 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm!
Attachment #697291 - Flags: review?(ahalberstadt) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/78454c7cecf3
Assignee: nobody → jgriffin
Whiteboard: [automation-needed-in-aurora][automation-needed-in-b2g18]
Target Milestone: --- → mozilla20

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/78454c7cecf3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/0b3d37abcb8f
https://hg.mozilla.org/releases/mozilla-b2g18/rev/25d3e0fa4e98
status-b2g18: --- → fixed
status-firefox19: --- → fixed
status-firefox20: --- → fixed
Whiteboard: [automation-needed-in-aurora][automation-needed-in-b2g18]
(Assignee)

Updated

5 years ago
Duplicate of this bug: 826182
You need to log in before you can comment on or make changes to this bug.