Closed Bug 826173 Opened 7 years ago Closed 7 years ago

Avoid calling close/fclose/unlink with uninitialized values in the linker

Categories

(Core :: mozglue, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

The switch to use mozilla::Scoped in bug 735615 effectively removed the checks that avoided calling close(-1), fclose(NULL) or unlink(NULL).
Attachment #697360 - Flags: review?(nfroyd) → review+
https://hg.mozilla.org/mozilla-central/rev/6bca41629a11
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Duplicate of this bug: 798057
You need to log in before you can comment on or make changes to this bug.