If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash in _cairo_surface_snapshot_copy_on_write while priting / hardware acceleration bug?

RESOLVED DUPLICATE of bug 740325

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 740325
5 years ago
2 years ago

People

(Reporter: smarttemplate4, Unassigned)

Tracking

({crash})

17 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

i have in my website a href with javascript:window.print(); but this cause firefox always to crash.



Actual results:

"Always" by reason that this crash only occurs when you have not print some minutes before your last print.
If you have sucessfully print before and print again this bug not occurs


Expected results:

print without crash firefox

Comment 1

5 years ago
Could you attach a minimal testcase, please?

In addition, type about:crashes in location bar and post some crash IDs (bp-...).

Does it happen with a fresh profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles (don't import anything)
Flags: needinfo?(smarttemplate4)
(Reporter)

Comment 2

5 years ago
minimal testcase?
I have explained in my bugdescritiopn what happend and when it occurs...
Sorry this is the first time that i submit any bugs here... need more infos

it happens on every a href with javascript window print
sorry didn't make "commercial" but here you can test it byself...
http://smarttemplate4.mozdev.org

Error ID's (all for the same problem)
bp-2f84e53a-4d11-4562-8c49-a7d182130103 - 03.01.2013 - 10:56
bp-944752f9-61af-42da-a35e-20da52130103 - 03.01.2013 - 10:09
bp-fadb4ad1-724e-4d93-b824-2dd902130103 - 03.01.2013 - 08:40
bp-bd09533d-35e6-460f-a6b9-daf602130103 - 03.01.2013 - 08:35
Flags: needinfo?(smarttemplate4)
This looks the same as bug 740325.
(Reporter)

Comment 4

5 years ago
yes it is, now i see this byself inside the log
"Firefox 17.0.1 Crash Report [@ _VEC_memcpy | _cairo_surface_snapshot_copy_on_write ]"
(Reporter)

Comment 5

5 years ago
bug can be set on confirmed needs fix (memory leak in firefox?) ;)
(Reporter)

Updated

5 years ago
Crash Signature: _VEC_memcpy | _cairo_surface_snapshot_copy_on_write
See Also: → bug 740325
(Reporter)

Updated

5 years ago
Severity: normal → major
Component: Untriaged → Event Handling
Keywords: crash, testcase-wanted
Product: Firefox → Core
(Reporter)

Updated

5 years ago
Severity: major → critical
Whiteboard: _VEC_memcpy

Comment 6

5 years ago
(In reply to smarttemplate4 from comment #2)
> minimal testcase?
> I have explained in my bugdescritiopn what happend and when it occurs...
> Sorry this is the first time that i submit any bugs here... need more infos
> 
> it happens on every a href with javascript window print
> sorry didn't make "commercial" but here you can test it byself...
> http://smarttemplate4.mozdev.org


By testcase, I mean a small HTML file or a link to reproduce the issue/crash.
On the website you linked, I tried to click on "Print" (bottom) but it didn't crash.
(Reporter)

Comment 7

5 years ago
mmhhh maybe we have different OS or something, my Problem isn't a single Problem lot of user have the same, see previous messages
It does not matter how many people have the problem.  If you can provide a simple set of steps with a simple example page to reproduce the issue, the likelihood a developer will be able to fix the issue is much greater.
(Reporter)

Comment 9

5 years ago
sure but in the description i have explained more i can't do...
maybe it's an OS or special Hardware Bug or something, most programmers work on linux and windoof is in most case the biggest bug ;)
(Reporter)

Comment 10

5 years ago
windoof means windows ;)

Comment 11

5 years ago
Could you paste the section "graphics" from about:support please.

In addition, could you try with hardware acceleration disabled (Options > Advanced > General, restart FF17). Does it crash with HWA off too?
(Reporter)

Comment 12

5 years ago
no without activated hardware accrelation it don't occur or maybe only currently not.
I'm not really sure what's the reason for the problem...
(Reporter)

Comment 13

5 years ago
Created attachment 698095 [details]
requested screenshot (german)
(Reporter)

Comment 14

5 years ago
Created attachment 698241 [details]
now screenshot of graphics section only
(Reporter)

Updated

5 years ago
OS: Windows 7 → All
Hardware: x86 → All
Summary: javascript:window.print(); in a href cause firefox always to crash → crash in _cairo_surface_snapshot_copy_on_write while priting / hardware acceleration bug?
(Reporter)

Comment 15

5 years ago
i think it's an foolish hardware acceleration bug.
Please see additional this
https://bugzilla.mozilla.org/buglist.cgi?quicksearch=_VEC_memcpy

Testcase for all which have this Problem
Try follow: disable hardware acceleration (Options > Advanced > General, restart
Do crash now too?
Then enable hardware acceleration again (don't forget to restart)
Do it crash now again?
For me is this really the one and only solution to disable hardware acceleration - no crash while printing since this change in settings.

It will be great if more user can check this so that a developer can fix this bug, this occur since FF/TB 15 if i have see this right!
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ sounds not nice!

Updated

5 years ago
Component: Event Handling → Graphics
Whiteboard: _VEC_memcpy

Comment 16

5 years ago
(In reply to Bill Gianopoulos [:WG9s] from comment #3)
> This looks the same as bug 740325.
It's indeed a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 740325
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.