[Everything.me] When selectting more button, phone only display "Loading..." screen

RESOLVED FIXED

Status

Firefox OS
Gaia::Everything.me
--
blocker
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: ranbena)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
1. Title : When selectting more button, phone only display  "Loading..." screen
2. Precondition : 
3. Tester's Action : Home - Everything screen - Select more - Display only "Loading..." screen
4. Detailed Symptom (ENG.) : Before cancel button is pressed, "Loading.." screen doesn't disappear.
5. Detailed Symptom (KOR.) : 
6. Expected : After a few seconds, it will disappear or show some categry list. 
7.Reproducibility: Y
1)Frequency Rate : 100%
8.Comparison Results : 
1)Model Comparing : 
9. Attached files: 
1)Log : 
2)Test Contents : 
3)Video file :
Just a stupid question, are you sure you have an internet connection available? Is working fine in unagi with today´s nightly.
(Reporter)

Comment 2

5 years ago
Sorry! I didn't describe precondition.
That case only happens when an internet isn't connected.
Plz consider an expected situation.
It's by design but we're open for UX suggestions.
I'll discuss this with the UX team.
Discussed with Rafa. Decided on a a system alert message saying "You must connect to the internet in order to..."
Created attachment 699055 [details]
Added system alert

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #699055 - Flags: review?(crdlc)
Attachment #699055 - Flags: approval-gaia-master?(21)
(Assignee)

Updated

5 years ago
Assignee: nobody → ran
Comment on attachment 699055 [details]
Added system alert

<html>
<head>
<meta http-equiv="Refresh" content="2; url=https://github.com/mozilla-b2g/gaia/pull/7357">
</head>
<body>
Redirect to pull request 7357
</body>
</html>
Created attachment 699057 [details]
Added system alert

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #699055 - Attachment is obsolete: true
Attachment #699055 - Flags: review?(crdlc)
Attachment #699055 - Flags: approval-gaia-master?(21)
Attachment #699057 - Flags: review?(crdlc)
Attachment #699057 - Flags: approval-gaia-master?(21)
Created attachment 699058 [details]
Added system alert

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #699057 - Attachment is obsolete: true
Attachment #699057 - Flags: review?(crdlc)
Attachment #699057 - Flags: approval-gaia-master?(21)
Attachment #699058 - Flags: review?(crdlc)
Attachment #699058 - Flags: approval-gaia-master?(21)
only a question for r+

and ask for l10n reviewer please
Status: NEW → ASSIGNED
Axel, can you take a look and make sure the L10n is cool?
Flags: needinfo?(axel)

Updated

5 years ago
Flags: needinfo?(axel)

Comment 11

5 years ago
You're mixing en-US and localized strings in https://github.com/mozilla-b2g/gaia/pull/7357/files#L0R1170, that's not gonna work. Probably best to have a string each.
Right. Changed. 10x!
Attachment #699058 - Flags: review?(crdlc) → review+
(Assignee)

Updated

5 years ago
Flags: needinfo?(l10n)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 827972

Comment 14

5 years ago
yep, this patch looks cool, thanks.
Flags: needinfo?(l10n)
Attachment #699058 - Flags: approval-gaia-master?(21) → approval-gaia-master+
https://github.com/mozilla-b2g/gaia/commit/793e544ee6a7dfd6a5a8ad0db9a8a39cb64c7d26
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.