Closed Bug 826361 Opened 10 years ago Closed 10 years ago

tumblr.com doesn't recognize B2G UA as mobile

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lmandel, Assigned: karlcow)

References

()

Details

(Whiteboard: [uaoverride] [country-all] [sitewait] [serversniff])

tumblr.com serves a desktop site to B2G. Bug 819210 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
Johnny, 
Could you put us in contact with the right person at Tumblr?
Basically the people in charge of the backend Tumblr infrastructure doing user agent sniffing. 

Thanks.



→ mozua.sh list tumblr.com

1854 KB/s (13901 bytes in 0.007s)
Listing domain matching tumblr.com
826361 tumblr.com

→ mozua.sh remove tumblr.com

2173 KB/s (13901 bytes in 0.006s)
Removing UA override for tumblr.com
+ adb shell mount -o rw,remount /system
+ adb push /tmp/user.js.tmp /system/b2g/defaults/pref/user.js
1256 KB/s (13811 bytes in 0.010s)
+ adb shell mount -o ro,remount /system
+ adb shell stop b2g
+ adb shell start b2g

After removing the domain, we get the desktop site which is basically unusable even for logging. There are strange overlays on a small screen, which makes near impossible to select the login area.
Flags: needinfo?(johnny)
Whiteboard: [uaoverride] → [uaoverride] [sitewait]
Trying to contact @codingjester http://twitter.com/karlpro/status/360097326456516608
Assignee: nobody → kdubost
Ah very cool. CodingJester is helping us to fill a bug internally. http://twitter.com/codingjester/status/360128014903803904 Thanks!
And this is a FIXED! Thanks a lot to codingjester and tumblr.
http://twitter.com/codingjester/status/360488968388755456
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: needinfo?(johnny)
Resolution: --- → FIXED
That will be fixed once we remove our override.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
@fabrice

Could you please not modified the bug without requesting please. :)

Tumblr has fixed the issue on their server, which is what the issue is about. 
What you are talking about aka removing the UA override is Bug 899162 
https://github.com/mozilla-b2g/gaia/pull/11228
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
See Also: → 899162
Karl, let's mark each UA override removal bug as blocked by the UA override tech evangelism bug so that we have the appropriate links in place.
Blocks: 899162
OK I screwed up in the PR on github. :) My bad. The title has a very precise syntax :) I will make sure to add that the guide. 
https://wiki.mozilla.org/Compatibility/Mobile/WipeOutUAOverides#Updating_the_UA_override_list

Thanks Fabrice for explaining on IRC.
fixing the flags for the stats
Whiteboard: [uaoverride] [sitewait] → [uaoverride] [country-all] [sitewait] [serversniff]
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.