Bluetooth Search for Devices not functional after first use

RESOLVED INVALID

Status

Firefox OS
Gaia::Settings
P1
normal
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Greg Grisco, Assigned: dkuo)

Tracking

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [cr 436595])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
1. Turn on bluetooth
2. Once inquiry completes, click on "Search for devices"

Expected result:  inquiry will complete and "Search for devices" button will become functional again.

Actual result: inquiry completes, but "Search for devices" button remains greyed-out (disabled).
(Reporter)

Updated

5 years ago
Whiteboard: cr 436595
Blocks: 808607
blocking-basecamp: --- → ?
Whiteboard: cr 436595 → [cr 436595]
Reproduced on Unagi, 1/3 build Nightly channel.
Assignee: nobody → ehung
blocking-basecamp: ? → +
OS: Windows 7 → Gonk (Firefox OS)
Priority: -- → P1
Target Milestone: --- → B2G C4 (2jan on)
(Assignee)

Updated

5 years ago
QA Contact: dkuo
(Assignee)

Updated

5 years ago
Assignee: ehung → dkuo
QA Contact: dkuo
By design, the "Search for devices" button will be enabled after 60 seconds, that means within this time period, the search is continued, not a one-time inquiry, so you will see the small "searching for devices..." label is there and if there is a new device found, it will be appended on the list.
Not quite sure the meaning of "inquiry completes"... if you see the "searching for devices..." is gone, but the "Search for devices" is still greyed-out, that must be a UI bug.
(Assignee)

Comment 3

5 years ago
Created attachment 697806 [details]
Search screenshots for bluetooth
(Assignee)

Comment 4

5 years ago
Please see the attached screenshots, one shows the bluetooth searching UI and another one shows the searching is complete after every 60 seconds. They are both captured from my unagi.

We can see while bluetooth is searching, there will be a "Searching for devices..." string indicating that we are in searching mode, also the "Search for devices" button will be greyed-out.

After search completes, the "Searching for devices..." string will disappear and the "Search for devices" button will be enabled for users to manually search again by pressing that button.

I believe this is a correct UX for bluetooth searching so not a bug actually. One possible is that the "Searching for devices..." string disappears but the "Search for devices" button is still disabled(greyed-out), just like Evelyn said, that should be a UI bug, but I am not able to reproduce this.

ggrisco, can you screenshot what you have seen for us? thanks.
(Reporter)

Comment 5

5 years ago
I think we just weren't being patient enough, not realizing that search would complete after 60 seconds.  By "Inquiry Completes" I think we meant that no new BT devices were being added to the search results, so we were somewhat expecting the "Search for devices" button to become enabled at that time.  Looks like this works as designed.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.