Switching between camera to video recording crashes pretty consistently

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash, reproducible, unagi})

unspecified
ARM
Gonk (Firefox OS)
crash, reproducible, unagi

Firefox Tracking Flags

(blocking-basecamp:-, b2g18+, b2g18-v1.0.1 affected)

Details

(Whiteboard: [b2g-crash])

Attachments

(1 attachment)

Created attachment 697690 [details]
Logcat filtered on camera during crash scenario

Similar to David's Bug 824435, but this is a crash and not a freeze. Bug 820139 was fixed, so maybe that fix didn't address the entire issue. Seen while running unagi using:

Gecko:
Gaia:

STR:
1. Start with the camera mode and take a picture.
2. Move to video recording mode and start a video and stop it.
3. After that I switch back and forth rapidly between camera mode and video mode.
4. Eventually I get a message that "Camera just crashed" or "just crashed"

Sometimes I notice that it happens more regular when I tap one of the buttons rapidly.

My crash report: https://crash-stats.mozilla.com/report/index/e72d94c3-542b-4335-a194-1baff2130103 - however it is unfortunately not useful.
Triage: BB-, tracking-b2g18+
seems only reproducible if you do the switch very quickly and intentionally trying to break it.
Assignee: nobody → dflanagan
blocking-basecamp: ? → -
tracking-b2g18: --- → +
cc'ing Dale.

Feel free to steal this if you want it Dale.
I suppose there could be a timing issue here... while trying to initialize whatever camera hardware is being initialized, the user switches back and forth and triggers another call to the camera initialization code.  If that's the problem the easiest solution might be to disable the switch button until the switch is complete.
stoled
Assignee: dflanagan → dale
The switch button is only enabled once the previewstream is enabled, we had this bug before and the fix was tested quite extensively. I have tried reproducing it on both otoro and unagi and cant.

It seems like this must be a build issue, I have tried flashing several builds

Updated

6 years ago
Severity: normal → critical
Whiteboard: [b2g-crash]
mike this is a pretty vague bug, would it have been fixed by various other camera related fixes? I am unable to reproduce.
Assignee: dale → nobody
Flags: needinfo?(mhabicher)
daleharvey, yeah, I believe we've addressed this with a number of fixen.

marcia, do you still see this at all?
Flags: needinfo?(mhabicher)
marcia, do you still see this issue at all? If not, I think we can close it.
Flags: needinfo?(mozillamarcia.knous)
Duplicate of this bug: 824435
On V1 train there is a crash whenever you touch video recording, so I can retry this when that bug has been addressed.
Flags: needinfo?(mozillamarcia.knous)
(In reply to Marcia Knous [:marcia] from comment #10)
>
> On V1 train there is a crash whenever you touch video recording, so I can
> retry this when that bug has been addressed.

Yeah, that is (was?) bug 872170.  Thanks, Marcia!

Updated

6 years ago
status-b2g18-v1.0.1: --- → affected

Updated

6 years ago
Whiteboard: [b2g-crash] → [b2g-crash] inarirun2
Hi Sarah, do your extra tags mean you are still able to reproduce this specific issue?  (As opposed to the issue in bug 872170?)
Flags: needinfo?(sparsons)

Comment 13

6 years ago
Hey Mike, I added those tags before I saw your last comment (comment 11) The issue I reproduced was bug 872170. Sorry about that!
Flags: needinfo?(sparsons)

Updated

6 years ago
Whiteboard: [b2g-crash] inarirun2 → [b2g-crash]
Bugs cleanup. This is obsolete. After the camera refactor/redesig that landed in 1.4 this doesn't apply anymore.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.