Missing horizontal scroll bar

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
17 years ago
3 years ago

People

(Reporter: bobj, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Trunk build 2001052404 on US Win95.

Go to http://www.intel.com/.
Adjust the window size to be narrower than the page.
No horizontal scroll bar appears.

Works on Netscape 4.x.
(Reporter)

Updated

17 years ago
Keywords: 4xp

Comment 1

16 years ago
I'm seeing this on all sites.

Tested using build 2001080203 on Win2k (SP2)

Like the reporter says, "Adjust the window size to be narrower than the page.
No horizontal scroll bar appears."

The area where the scrollbar should be is clickable and you can go back and
forth horizontally by clicking in the open area or by clicking the arrows.

This may simply be a css problem no displaying the scrollbar in the chrome or
something???

Jake

Comment 2

16 years ago
This seems to be skin specific.  I see no horizontal scrollbars for form 
widgets or for the browser itself with the Modern skin.  The vertical scrollbar 
is fine in both cases.

I do see horizontal scrollbars or the classic skin, however, they are very thin 
and don't take up the full space that they are given.  Additionally, the 
vertical scrollbars for the classic skin are doing the same thing as the 
horizontal scrollbars (thin).

I think the component should be Skinabillity.  Any disagreements???

Jake

Comment 3

16 years ago
i'm seeing this on all sites

i'm using build 2001080203 on WinNT 4.0

Comment 4

16 years ago
Me neither. There is a scrollbar that you can drag but it's not visisble so it
might be hard cliking the right places. I've only seen this for 1-2 days so I
don't think it's the bug bobj originally reported. Should this report be morphed?

Comment 5

16 years ago
In modern skin, if I select Preformat in the editor and then type until I get to
the edge of the page, the horizontal scrollbar trough appears, but there's no
scrollbar thumb in it to drag.

Comment 6

16 years ago
No horizontal scrollbars at all with 2001080303 Win32 trunk build. This is a new
regression.

Nominating for a blocker moz0.9.4 bug.
Severity: normal → blocker
Keywords: mozilla0.9.4, regression

Comment 7

16 years ago
Created attachment 44614 [details]
This is how the horizontal scrollbar looks now

Comment 8

16 years ago
This bug is a layout bug about scrollbar not wisible on some wide pages. 

The new problem of the missing thumb in the horizontal scrollbar reported in
recent days for the Modern skin is a new bug. I reported it today as bug 93548.
Severity: blocker → normal
Keywords: mozilla0.9.4, regression

Comment 9

16 years ago
It seems the missing thumb part of this bug is a dup of 93193.

Comment 10

16 years ago
petersen, can you develop a reduced test case. Reassigning to alexsavulov for 
analysis/triage.
Assignee: karnaze → alexsavulov
Keywords: qawanted

Comment 11

16 years ago
WFM with trunk Win32 build 2001080603 on WindowsME.

Comment 12

16 years ago
WFM, OS: Win 2000, Build 2001083103
(Assignee)

Comment 13

16 years ago
URL not relevant
scrollbar displays correctly
works for me
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.