[email] clicking the x on any of the fields will clear all fields for the email setup.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::E-Mail
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({polish})

unspecified
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(b2g18+)

Details

(Whiteboard: uxbranch)

## Environment :
Unagi phone, build 2013-1-03

## Repro :
1. launch email after flashing or go to account setup
2. type in all 3 fields
3. select x on the second field

## Expected :
1. only the second field will clear

## Actual :
1. all fields clear

## Note :
1. all fields clear then submits for the 3rd field; 1st field will also clear the second and third field.
I don't think it's a blocker, but when you hit it... well, quite aggravating since you typed a bunch of stuff, and you only want one field cleared.
Yeah, it's pretty annoying.  I had filed https://github.com/mozilla-b2g/Gaia-UI-Building-Blocks/issues/59 against the building blocks which have punted on the issue.
Duplicate of this bug: 827597

Comment 4

5 years ago
Unagi, build 2013-1-12

when select "x" field does not clear, "x" disappears though...
happens in all of the three fields
I don't think this is blocking, but I'm placing this as tracking.

Note: the patch in bug 830127 doesn't fix the issue... I thought it might be related, but I guess not...
tracking-firefox18: --- → ?
Whiteboard: uxbranch

Updated

5 years ago
tracking-b2g18: --- → ?
tracking-firefox18: ? → ---

Updated

5 years ago
tracking-b2g18: ? → +
Naoki, is this bug still valid? It works for me on latest master (f658741) and v1-train (c614b3f). Changing the status to RESOLVED > WFM for now, feel free to reopen if this is still reproducible.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(nhirata.bugzilla)
Resolution: --- → WORKSFORME
I believe that it may have been resolved through building block changes.  This no longer occurs.
Flags: needinfo?(nhirata.bugzilla)
djf fixed it in bug 833300
You need to log in before you can comment on or make changes to this bug.