Asus/AMD Booting Problems with Firefox

RESOLVED WORKSFORME

Status

()

Firefox
Shell Integration
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: ewen8, Unassigned)

Tracking

18 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20121231071231

Steps to reproduce:

My computer fails to start up - hard drive not recognized. Go into Bios and use a workaround to get it to boot up but it still locks up constantly. Fresh install the O/S (XP) and everything is fine until I reload Firefox / Thunderbird then it starts to lock up etc. I think the problem is associated with Asus motherboard M4A78LT MLE as I have a spare computer running with a Gigabyte board which is not affected.

My grandson has an Asus board in his computer and was affected in the same way. I have reloaded his system and banned him from using Firefox and Thunderbird.

The problem started about 70 days ago and initially I thought that it was some sort of Virus but after much head scratching and communication with Avast, I found that there was some corruption of the data in the BIOS - reconfiging the MBR would temporarily cure the problem.

I like your 2 browsers and would like to continue using them.  

Please advise.

Cheers,    Ewen Band.

Comment 1

6 years ago
See also: http://www.asus.com/Motherboards/AMD_AM3/M4A78LTM_LE/#specifications

This isn't security sensitive.

It would be very helpful if you can give the exact sequence of events that lead to the lock up, such as which programs are started, which urls are loaded, etc.

Since your grandson is also seeing similar issues with an Asus board it doesn't sound like it is limited to a hardware fault in your computer. Are both boards identical? I assume both are AMD boards. Can you give more information on the boards, cpus, memory, graphics cards?

It would be helpful if you can check previous versions of Firefox and see if the issue began with a specific version.

http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/13.0.1/win32/en-GB/
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/14.0.1/win32/en-GB/
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/15.0.1/win32/en-GB/
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/16.0.1/win32/en-GB/
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/17.0.1/win32/en-GB/
Group: core-security
Summary: Booting Problems with Firefox → Asus/AMD Booting Problems with Firefox

Updated

6 years ago
Flags: needinfo?(ewen8)

Comment 2

6 years ago
> hard drive not recognized

What is the exact message & at what point do you get it?
(Sounds like your HDD is failing.)

> Go into Bios and use a workaround

And just what is this workaround?

> Fresh install the O/S (XP) and everything is fine until I reload Firefox

Again sounds like HDD issue.  Until you happen to hit a particular sector on the HDD all is well, but once you do, fail.

> My grandson has an Asus board in his computer and was affected in the same way

Is it the same MB?  Same CPU?

> some corruption of the data in the BIOS
> reconfiging the MBR would temporarily cure the problem

BIOS & MBR are different.
What was the corruption in the BIOS?
What did you do & how did you reconfigure the MBR?
 
 
I would run a CHKDSK & or drive manufactures diagnostic on your HDD.
(Backup too, but don't necessarily rely on it.)
 
 
"The BIOS does not detect or recognize the ATA / SATA hard drive"
http://knowledge.seagate.com/articles/en_US/FAQ/168595en
(Reporter)

Comment 3

6 years ago
(In reply to therube from comment #2)
> > hard drive not recognized
> On starting from off, the computer shows a message that it cannot find a harddrive / operating system. On checking in the Set Up Screen (BIOS) there is no hard drive recognised.
> What is the exact message & at what point do you get it?
> (Sounds like your HDD is failing.)
> I have run various checks on the hard drive and also fitted another HD and reinstalled XP.
> > Go into Bios and use a workaround
> Have found a number of ways to workaround  -  change the Sata cable to another port on the motherboard  or  reset the bios by shorting the pins on the motherboard  or  disconnect the sata cable, start and stop the computer, reconnect the cable. I have been fighting this for about 3 months !!!! I have been using my spare computer which has a Gigabyte mb fitted and is totally unaffected - thankfully.
> And just what is this workaround?
> 
> > Fresh install the O/S (XP) and everything is fine until I reload Firefox
> Can sometimes be a few days before problems occur and it is always during general surfing the web and not associated with any particular site or type of site.
> Again sounds like HDD issue.  Until you happen to hit a particular sector on
> the HDD all is well, but once you do, fail.
> 
> > My grandson has an Asus board in his computer and was affected in the same way
> His board is Asus M4N68T MLE V2
> Is it the same MB?  Same CPU?
> Both CPU's are AMD Athlon II, X2 and X4 running at about 3.0 Ghz
> > some corruption of the data in the BIOS
> > reconfiging the MBR would temporarily cure the problem
> 
> BIOS & MBR are different.
> What was the corruption in the BIOS?
> What did you do & how did you reconfigure the MBR?
>  Avast supplied me with a small programme which checked and reset the MBR.
Although I have worked out wherein the problem lies, this whole episode is a learning curve for me. I am an enthusiastic amateur but keen to learn. Even my very knowledgeable friends are out of their depth.(as I am)
I normally use Acronis (images) as a last resort to sort problems, but this is not as simple as reloading an image.
I would greatly appreciate any links that explains how MBR / BIOS really work in detail.
>  
> I would run a CHKDSK & or drive manufactures diagnostic on your HDD.
> (Backup too, but don't necessarily rely on it.)
> Have done, but they did not show any problems. 
>  
> "The BIOS does not detect or recognize the ATA / SATA hard drive"
> http://knowledge.seagate.com/articles/en_US/FAQ/168595en
Flags: needinfo?(ewen8)
(Reporter)

Comment 4

6 years ago
Sorry, forgot to add information about which Firefox version. I use a site called Oldversion.com and have tried various versions of Firefox to no avail. Perhaps this would point to there being another factor such as Microsoft Updates (god forbide for implying such a thing) or Java who are constantly altering things.

Comment 5

6 years ago
As therube suggested, did you run chkdsk against drive containing Firefox profile?
Also, provide S.M.A.R.T. report from CrystalDiskInfo - http://crystalmark.info/download/index-e.html#CrystalDiskInfo
Flags: needinfo?(ewen8)

Updated

6 years ago
Component: Untriaged → General
(Reporter)

Comment 6

6 years ago
I have run both requested programmes and both reported no problems. I will send screen captures for both if you tell me how to.
Flags: needinfo?(ewen8)

Comment 7

6 years ago
No need to send screenshots, in CrystalDiskInfo select Edit - Copy, paste text to pastebin.mozilla.org and provide link here

Updated

6 years ago
Component: General → Shell Integration
(Reporter)

Comment 8

6 years ago
\I am struggling a bit with this.
http://pastebin.mozilla.org/2067449
or E Band

Comment 9

6 years ago
Hardware thinks that drive is completely fine, next two steps
1) Download and run surface tests (not erase!!!) with http://www.seagate.com/support/downloads/seatools/seatools-win-master/
2) After that, run again disk check with /F /R command line switches

Comment 10

5 years ago
ewen, do you still have this problem?
Flags: needinfo?(ewen8)
Whiteboard: closeme INCO 2013-06-01
(Reporter)

Comment 11

5 years ago
Hi,

Sorry for the delayed reply but I have been on holiday.  I have had one more incidence of the same problem since I last contacted you.

The first signs of a problem is when I get lockup. I watched carefully and it occurs when the computer tries to do two things at the same time (ie when I input some action while it is running say the security program.)

I scrubbed the Hard drive and reformatted it. It has now been running for 9 weeks with no problems. But have been very careful what I have connected to it as regards :-

Other storage hard drives.

All my contacts and bookmarked websites in Firefox and Thunderbird.

No USB sticks connected so far.

I will let you know when I work out what triggers the problem.

Cheers,     Ewen.
Flags: needinfo?(ewen8)

Comment 12

5 years ago
Ok, free to reopen if you see this again
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: closeme INCO 2013-06-01
You need to log in before you can comment on or make changes to this bug.