Note: There are a few cases of duplicates in user autocompletion which are being worked on.

selecting octet-stream url does not include http://

RESOLVED INVALID

Status

()

Firefox
Location Bar
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: karlt, Unassigned)

Tracking

({regression})

7 Branch
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
1) Load http://www.clearlite.co.nz/Platinum-II-P72.aspx
2) Middle click "Shower Install Tray and Liner PDF".

1) Enter http://www.clearlite.co.nz/download.ashx?DigitalGoodId=237 in url bar.
2) Press return.
   "www.clearlite.co.nz/download.ashx?DigitalGoodId=237" is shown.
3) Cancel dialog.
4) Select text from url bar.
5) Copy and paste if your OS requires, to view content of selection.

expected: clipboard/selection includes http://
actual: no "http://" in clipboard/selection.

Possibly the same cause as bug 680972.
I'm a bit confused about the first two steps you list, since they don't seem related to the next set of steps. Platform differences may also contributing to the confusion. Could you elaborate a little on the steps to reproduce and what happens after each step?

Given what I've tried, I can't reproduce this on Mac - copying the URL after cancelling the dialog includes the "http://" prefix.
(Reporter)

Comment 2

5 years ago
Sorry, this is a combination of a miss-copy and I think getting confused over which versions I was testing.  The bug for the second set of steps seems to have been fixed since 7.  I'll start again in a new bug.
No longer blocks: 665580
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 680972
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.