If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[email/activesync] Deleting/moving messages causes them to show up twice in the target folder

RESOLVED FIXED in B2G C4 (2jan on)

Status

Firefox OS
Gaia::E-Mail
P3
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: squib, Assigned: squib)

Tracking

unspecified
B2G C4 (2jan on)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Assignee)

Description

5 years ago
ActiveSync isn't handling delete/move operations correctly, so we end up with duplicates (one from the local op, and one from the remote op). We need to fix this.
(Assignee)

Comment 1

5 years ago
I have a fix in-progress on my unit test branch, but I want to flesh out the tests a bit more before I put it up for review: https://github.com/mozsquib/gaia-email-libs-and-more/tree/as-unit-tests
Triage: BB+, C4, P3
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C4 (2jan on)
Assignee: nobody → squibblyflabbetydoo
How is this one coming along?
(Assignee)

Comment 4

5 years ago
Checked in: https://github.com/mozilla-b2g/gaia-email-libs-and-more/pull/109
            https://github.com/mozilla-b2g/gaia/pull/7344
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 5

5 years ago
Issue reproduces in build 20130112070202 for Unagi 

Edit options are blocking after the attempt to delete message from Trash folder, 
User is no longer able to move, delete, flag or mark read/unread - status message confirms the actions but nothing is going on with the messages

## STR
have a few msgs on your Hotmail account

1. Add Hotmail account on device (enter credentials ==> tap Next ==> tap Continue to Mail) 
2. From Inbox folder select unread msg => back to Inbox, msg shown as read
3. Select Edit 
4. Select a msg to Flag => back to Inbox, msg shown as flagged
5. Select Edit
6. Select a msg to Move to Trash => status message confirms msg moved to Trash and msg disappears from Inbox
7. Go to Trash folder
8. Select Edit
9. Select a msg to Delete ==> ACTUAL RESULT! - status msg states message been deleted, however message is still in the Trash folder
10. Try to repeat steps 2-6 ==> ACTUAL RESULT! - not able to perform adequately any of the Edit options
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

5 years ago
(In reply to nkot from comment #5)
> Issue reproduces in build 20130112070202 for Unagi 
> 
> Edit options are blocking after the attempt to delete message from Trash
> folder...

This is a separate bug, and doesn't have anything to do with ActiveSync. The issue is that our local op deadlocks because we try to open the trash folder for modification twice.
Closing per comment 6.

General rule - file a separate bug if you notice something isn't working on the original bug and link it. Avoid reopening in most cases from resolved fixed. It makes tracking blockers a royal pain if we reopen.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 8

5 years ago
will do, sorry, in this particular case bug has been already filed, #823521
You need to log in before you can comment on or make changes to this bug.