Closed Bug 826589 Opened 8 years ago Closed 8 years ago

Apps in activity selector are not using translated name

Categories

(Firefox OS Graveyard :: General, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed)

RESOLVED FIXED
B2G C4 (2jan on)
blocking-basecamp +
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- fixed
b2g18 --- fixed

People

(Reporter: alive, Assigned: Margaret)

References

Details

Attachments

(2 files)

STR:

1. Change the language to non-English
2. Use any activity
* Long press home
* Click share in Gallery app

Expected:
* The app names are translated when you are choosing the activity target

Actual:
* The app names are in English

Note:
* There's another bug in activity: the name of activity action is not translated.
* e.g. pick in selecting wallpaper case. I'll file another bug for this.
Triage: BB+, C4, p3
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C4 (2jan on)
Make sure to use the new ManifestHelper object.
Duplicate of this bug: 827057
so is this a localization fix, or will using the ManifestHelper object end up getting the right strings and resolve?
Alive, can I steal this? :)
I'd like to say yes because this seems a platform issue.

ActivitiesGlue doesn't provide identifier to app but a translated English name of the app.
Also, it doesn't deal with entry points. That means, we get 'Communications' instead of 'Contact' when picking a contact info.

Notice: If activitiesGlue is willing to provide origin to system app, WindowManager has working function to get the translated name. Just reference the name field in runningApps.

(In reply to Etienne Segonzac (:etienne) from comment #5)
> Alive, can I steal this? :)
Uh...there's very dirty solution.
Look up the translated name provided by Gecko/ActivitiesGlue in Gaia/ManifestHelper.
And then use the manifest object to fetch to localized name...but this seems too dirty because we couldn't guarantee the translated name is unique :/ Also this couldn't resolve the entry point issue.

I think Margaret would be interesting in stealing this in platform?
I can take this.
Assignee: alive → margaret.leibovic
(In reply to Margaret Leibovic [:margaret] from comment #8)
> I can take this.

Cool I'm in no position to steal bug anymore :)
Component: Gaia::System → General
I came up with a solution that changes the gecko side of things to stop storing the app titles, and instead pass along the manifest url to gaia so that we can localize the app names when we show the activity picker.

Is there someone besides fabrice who can review this sooner?
Attachment #698673 - Flags: review?(fabrice)
Comment on attachment 698673 [details] [diff] [review]
(Part 1) Pass manifest to activity picker instead of pre-translated title

Maybe Vivien wants to review this :)
Attachment #698673 - Flags: review?(21)
Comment on attachment 698676 [details] [diff] [review]
(Part 2) Use localized app name in activity picker

Review of attachment 698676 [details] [diff] [review]:
-----------------------------------------------------------------

Looks simple and good. r=me if you have tested it ;)
Attachment #698676 - Flags: review?(alive) → review+
Comment on attachment 698673 [details] [diff] [review]
(Part 1) Pass manifest to activity picker instead of pre-translated title

LGTM :)
Attachment #698673 - Flags: review+
Attachment #698673 - Flags: review?(fabrice)
Attachment #698673 - Flags: review?(21)
Comment on attachment 698673 [details] [diff] [review]
(Part 1) Pass manifest to activity picker instead of pre-translated title

Review of attachment 698673 [details] [diff] [review]:
-----------------------------------------------------------------

I can't remember why saved the title in the original impl and I don't think it harms to not store it anymore.
This missed the merge for mozilla20 - reflecting in flags.

(Also, normally bugs are left open until they merge to mozilla-central :-))
You need to log in before you can comment on or make changes to this bug.